0

This is the symptom/issue - I am using a subdomain, and latest Wordpress Rev, as well as PHP on server. When signed in to my site as admin, if I choose admin/customize, I get a new signon screen within a frame and message "Session expired. Please log in again. You will not move away from this page."

I've confirmed this error occurs regardless of theme. And WordPress Address (URL) & Site Address (URL) match.

Last, for what it's worth, I've had this subdomain running for well over a year with no issues, it only shows this symptom recently. As if the Rev of WP were the issue.

UPDATE - I backed up my data, and reinstalled from scratch. The problem is no longer appearing.

  • It is unlikely that anyone will be able to guess without access to your server. Obviously you have some cookie problem but it is impossible to guess from the symptoms what is the cause. – Mark Kaplun Sep 26 '15 at 18:01
  • I appreciate the comment. When something runs for a long time and suddenly 'breaks' I was hopeful that I wasn't the only one. If using subdomains is common, maybe others are seeing the same issue. If not, I have little understanding how to start troubleshooting. – JoeTaxpayer Sep 26 '15 at 18:05
  • it always possible that something changed on your PC. can you recreate it on another computer? I don't think there was any cookie related change it 4.3. – Mark Kaplun Sep 26 '15 at 18:12
  • Just checked - same issue on other PC. – JoeTaxpayer Sep 26 '15 at 19:00
  • Like Mark mentioned, its bit difficult to mention the exact cause unless we have atleast your website URL. The issue could be with setting up cookie which may happen if you have different siteurl and homeurl. To give it a try, please edit your wp-config.php file and add these two: define( 'WP_HOME', 'abc.example.com/'); define( 'WP_SITEURL', 'abc.example.com/'); Please replace abc.example.com with your actual subdomain. The thing to make sure is both URLs should match. – Prasad Nevase Sep 28 '15 at 6:13
1
+50

The issue could be with setting up cookie which may happen if you have different siteurl and homeurl. To give it a try, please edit your wp-config.php file and add these two:


define( 'WP_HOME', 'abc.example.com/'); 
define( 'WP_SITEURL', 'abc.example.com/'); 

Please replace abc.example.com with your actual subdomain. The thing to make sure is both URLs should match.

If above does not resolve, then one more thing you can try is setting your cookie domain to the subdomain


define( 'COOKIE_DOMAIN', 'abc.example.com/'); 

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.