0

I have tried everything in every post I have been able to find about changing permalinks for existing posts and pages. I have gone to settings and change the permalink structure in hopes that it would reset it. This had no effect on "Pages".

If I change the title do "Page Title", then click the "Edit" for the permalink, and change it to "post-title", it will still not change it. It appears to work, but when I click "Update" it updates to the original permalink.

Does anyone have a direction or solution at getting this to work?

  • Are you running the latest version of WordPress? Have you tried testing with a default theme activated and all plugins disabled? – TheDeadMedic Sep 21 '15 at 17:03
1

Thank you TheDeadMedic, I should have tried this already, but here is the answer:

I had the "Slug" Meta-box hidden, using the "remove_meta_box" function because it is annoying, especially for users that aren't tech-savvy.

Unfortunately, Wordpress keeps the Permalink "Edit" as if you could edit it, but it is actually necessary for the "Slug" div to be on the page (even if it is hidden by "Screen Options"). Once I re-enabled the "Slug" div, it works again to change the permalinks.

0

My problem was a "featured image" . Remove the feature image, update, then I could change the permalink. Scratched my head for a long time on that one.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.