0

I'm not sure if this is a known WordPress Multisite bug, or the way the Multisite I am working on was setup. The kind of issue I am having is similar to this one.

The links created by get_author_posts_url() in the theme's functions.php file, to generate the link for the author, end up having an extra "/blog" in front of them and they should not. Within the child sites, the get_author_posts_url() generated links are all OK and do not contain the "/blog" in the URL string.

Here is the website. When you click on an author link from the featured post tiles, you get an error 404 page returned. If you go into on of the child blogs - it does not happen.

How can I remove "/blog" from the link string data generated by get_author_posts_url()?

For more info, please see my question on Stack Overflow.

  • hurrah, this post got 'tumbleweed' status! Can close this off as I solved the issue by using a .htaccess redirect rule. – Ryan Archer Oct 19 '15 at 1:50
0

I know you've resolved it using .htaccess, but this is generally something you can amend in the site settings in your Network admin. Go to Sites, click Edit, and then scroll down to find the permalink structure which probably look like this: /blog/%posttitle%.

Just remove the '/blog' part, click save and you'll probably find it's ok.

I did read somewhere that re-saving your permalinks over-rides this settings so you need to go back into the site via network admin to remove /blog again.

Hope that helps!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.