0

Within head tags of this post page (sorry there's a language selection prompt screen), Yoast SEO Plugin generates this:

<meta content="http://www.example.com/wp-content/uploads/2015/06/whatever.jpg" property="og:image">

Although the image linked here is Facebook compliant (above 200x200px), there's still no image appearing when pasting the post link into Facebook. Why?

2
  • 5
    I have posted the solution for you. As a side note, I noticed you've posted over 100 questions with no answers. I suggest that you use the valuable knowledge you have gained by contributing with answers too =)
    – Christine Cooper
    Sep 12, 2015 at 15:24
  • Thx Christine, I upvoted your answer but can't accept it as my problem remains unresolved. I'll try to follow your advice about answering questions though!
    – drake035
    Oct 1, 2015 at 20:53

1 Answer 1

4
+25

Facebook caches the meta values for performance. So it is currently hosting an old version of the shared URL. You need to use the Facebook debugger, and Fetch new scrap info.

This will update the stored meta values of the post.

To confirm that it works, I have already fetched new data for the respective URL and this is how it looks when I share it on FB:

enter image description here

Additionally, I should highlight that Facebook normally stores shared data in your FB user account as well. So in order for you to see the updated share, try with a different account. This is not always the case but I have seen this behaviour before so it's worth mentioning regardless.

7
  • Thanks Christine, but this seems to work only on a post basis. Using the FB debugger I can make it work for one post in particular, but the next post I'm trying to share doesn't work. I would have to do this for all posts and that's not really an option in my case... Any suggestion to make it work for the whole website?
    – drake035
    Sep 15, 2015 at 11:19
  • Sure, are you using any caching plugins? If so, clear the cache completely.
    – Christine Cooper
    Sep 15, 2015 at 12:02
  • I have no caching plugin of any kind running of this site I'm afraid...
    – drake035
    Sep 16, 2015 at 20:53
  • 1
    As a temporary hack you could try adding a query var to yoast's ouput using its filter: add_filter( 'wpseo_og_og_image', function ( $content ) { return $content . '?scrape=true'; } ); which according to a comment on this answer stackoverflow.com/a/10289336/664741 may cause FB to re-cache...please note may...!
    – bonger
    Sep 17, 2015 at 6:51
  • Great stuff @bonger! As a side-note, the only posts you should refresh are the ones that were shared on FB prior to you adding the yoast. Which I doubt are that many. Additionally, FB does indeed clear their stored data automatically after a set interval. I don't know what it's set to but I am sure about this as I have seen this behavior very often myself.
    – Christine Cooper
    Sep 17, 2015 at 14:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.