0

My Wordpress Dashboard is suddenly quite buggy. To be specific just the admin menu is buggy. When I navigate somewhere in admin area some of the menu items disappear as you can see on the following screen.

Buggy theme screen

After I move mouse over the menu some items re-appear but not correctly positioned as you can see on the next picture (see Updates text).

enter image description here

After I reload the page once or twice (reloading the same page, not navigating somewhere else) or Collapse and Expand menu again menu is fixed.

I don't use any plugins. I have tried to update Wordpress (manually) but it didn't help. I am currently using Wordpress 4.3, Google Chrome 45.0.2454.85 (Official Build) (64-bit), and Ubuntu 15.04.

I have just tested FireFox and there seams to be everything OK so it seams to be something with Chrome, but when I've checked console (in Chrome) there are no errors. The errors might have something to do with Chrome recent update.

1
  • This was already asked, so I linked to the original answer.
    – gdaniel
    Sep 8 '15 at 17:11
3

That's an issue with the latest version of Chrome. I am on version 45.0.2454.85 and had the same issue. See this article for the full details and solution.

http://wptavern.com/a-bug-in-chrome-45-causes-wordpress-admin-menu-to-break

enter image description here

0

Chrome 45 has a rendering bug. There is a ticket open on Chrome's bug tracker about this issue, hopefully they will fix it soon. In the meantime, here is a workaround to eliminate the issue in Chrome. - Go to chrome://flags/#disable-slimming-paint - Enable the "Disable slimming paint" option. - Ensure that the "Enable slimming paint" option below it is not turned on. - Relaunch Chrome. When you're done, the final result should look like this: https://cloudup.com/cddYghY8fBd This will disable the problem code in Chrome and allow the menus to render normally.

You can also use the following code to fix it for all your users. Add it to a plugin, theme, child theme, or even a mu plugin.

    add_action('admin_enqueue_scripts', 'chrome_fix');
function chrome_fix() {
    if ( strpos( $_SERVER['HTTP_USER_AGENT'], 'Chrome' ) !== false )
        wp_add_inline_style( 'wp-admin', '#adminmenu { transform: translateZ(0); }' );
}

You could also just use the follow code.

if ( strpos( $_SERVER['HTTP_USER_AGENT'], 'Chrome/45' ) !== false ) add_action('admin_head', create_function('', "echo \"<script type='text/javascript'>jQuery(window).load(function(){jQuery('#adminmenuwrap').hide().show(0);});</script>\";") );

Either of the three options should fix it for you, but you will need to use one of the code options if you are going to fix it for your users also.

You can also check out the ticket available on WordPress.

Not the answer you're looking for? Browse other questions tagged or ask your own question.