1

I am running wordpress 4.3 with my custom theme. Everything was going fine but today when i tried to post new article on my blog i notice that when i click on publish button it stuck on loading. I tried so many times but faced same problem. Please see attached screenshot. enter image description here

And that post saved as draft in (all posts). Then i clicked on quick edit and change the status draft to publish and then it publish successfully. Please see attached screenshot. enter image description here

Same thing happening with my pages too that i can not update or create new pages. I changed the theme everything is working fine. That means the problem is in my theme. I tried to find solution and tried all tips and tricks but could not resolve this issue.

1

You are most probably using an outdated version of Advanced Custom Fields plugin. I had the same issue. Updating to latest version fixed the issue.

  • I was having a similar issue and this was exactly it (I was actually using a beta version of an upcoming ACF update). So glad I found this! Thanks. – GreatBlakes Apr 11 '18 at 4:13
0

You want to isolate what changes were made that caused the issue. If there is any way of narrowing down when the problem started - i.e. after what code or plugin changes - that would be my first stop.

If you can't think of any suspects:

  1. Look in your browser's Javascript console and see if an error pops up when you try and publish the post. If so, the source (and type) of the error will hopefully give you a hint about the source of the problem.
  2. If there are no Javascript errors on publish, you may have an issue on the save post hook. Have there been any recent code changes using this hook?
  3. If you recently upgraded Wordpress through a manual process you could have accidentally missed adding/replacing some files in the process.

Still struggling to find the source of the issue?

  1. Check if it's a plugin issue: Disable all your plugins (in a dev environment), and then see if publishing now works properly. If so, it's probably not a plugin issue. If not, gradually re-enable plugins until you find the culprit, paying particular attention to the most recently enabled plugins.
  2. Check if it's a code issue: If you're on a version control system, roll back until you locate the last commit where the functionality worked, then see what code changes were made in the commit that broke things.
  • Did you recently upgrade your version of Wordpress through a manual process? (i.e. download the new version and copy over the files vs click an "upgrade" button) – Robert Rome Sep 2 '15 at 19:47
  • i got error in console (load-script.php). Please see screenshot prntscr.com/8bvnc5 i uploaded my load-sctips file with txt extension testserver.richcandies.com/myfiles/load-scripts.txt – Mohammad Kashif Sep 2 '15 at 19:49
  • So the error isn't necessarily in the load-scripts file itself, it could be in one of the scripts that file loads. Since it's a core Wordpress file I'm guessing there was an issue with how you upgraded your version of Wordpress. I'd try re-upgrading, being sure you don't accidentally leave out any new files and all existing core Wordpress files are fully overwritten. – Robert Rome Sep 2 '15 at 19:59
  • Yeah i did update the wordpress but after locating this problem. – Mohammad Kashif Sep 2 '15 at 20:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.