4

Before you say this has been dealt with before, please read the whole issue. I have Google'ed and Stackoverflowed myself to death on this.

In WMT I see 404 errors for /feed on specific posts. e.g. htt://mydomain/thispost/feed/ My feed is working fine for pages and categories but there is this ongoing 404 error for a feed on indivual posts.

I thought to block /feed in robots.txt but then all feeds will be blocked and I dont really know the impact from a SEO perspective.

Can someone please give me a solution or direction.

By the way my site is using WPML and WP SEO (Yoast)

Thank you in advance

1
  • 1
    go to settings and re-save permalinks page. sometimes this catches me out when I've added a custom RSS feed, this might help you.
    – Mat
    Sep 1 '15 at 13:37
1

For all those who might hit the same problem, here is the solution:

Disable in Yoast the "remove category" option in advanced section. Then install this plugin: https://wordpress.org/plugins/remove-category-url/ ( do use any other plugin as this one works - yes, I tried them all)

For some reason the Yoast solution and all other plugins don't allow accessing the /feed/ url in any language besides the default language of WPML.

Hope this will be useful someone out there..

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.