3

Ever since I updated my website to 4.3 my visual editor is freezing every time I try to highlight a piece of text, or even place my cursor someplace random. This only seems to be happening on the text contained within a HTML table. When I open console tab in Chrome, following error is displayed over and over again:

    Uncaught RangeError: Maximum call stack size exceeded -- tinymce.min.js?ver=4203-20150730:7

On a recommendation from people at WordPress forums I already tried disabling all of my addons, cleared my browser cache and my Cloudflare cache, and changed themes to Twenty Twelve. Nothing seems to help.

I even made a sub-domain, and installed a fresh copy of WordPress on it in order to test if my WordPress installation is broken. Nope. Same thing happens even on a completely new website running on 4.3.

I also have another website on the same host but I haven't updated it to 4.3 yet, and everything works smooth as ever there. No freezing whatsoever.

Another thing that I noticed is that the CPU usage on my PC goes to 60-70% when this error occurs, and then goes back to normal 2-5% when it unfreezes. I also recently updated to Windows 10, if that's of any importance.

To replicate this error, copy the HTML table code bellow and paste it couple of times in a new post - enough so that you can actually scroll the page. Then try scrolling the page in the Visual Editor with your mouse-wheel and while doing so try to select a piece of text. This without exception freezes my screen for good 4-5 seconds.

<h3>Title</h3>
<table>
<tbody>
<tr><td><p>Nulla ac vehicula nunc. Sed sed maximus lectus, a cursus ligula. Aliquam enim lacus, mollis quis vestibulum et, imperdiet et enim. Cum sociis natoque penatibus et magnis dis parturient montes, nascetur ridiculus mus. Curabitur eget gravida est, a vehicula tortor. Curabitur aliquam lorem justo, vitae maximus metus porttitor vel. Aliquam neque mauris, posuere a mauris sit amet, ullamcorper accumsan velit.</p><p>Aenean vitae condimentum lacus. Vivamus sit amet velit quis lectus dapibus laoreet. Fusce ultricies aliquet arcu ac lacinia. Vivamus a erat ut erat ornare bibendum vel vitae velit. Vestibulum ut tellus quis magna luctus scelerisque pulvinar sit amet orci. Pellentesque habitant morbi tristique senectus et netus et malesuada fames ac turpis egestas. In malesuada ligula in ante pharetra, id euismod est tempor.</p></td></tr>
</tbody>
</table>

Any idea of what might be causing this?

EDIT: Just tried on couple of other computers just to rule it out, and it happened on each one them. Is it a problem caused by caching perhaps? I am using CloudFlare, but I already purged files multiple times. Some people that are experiencing similar issues said that updating PHP to 5.4 helped, but I'm already running that version.

EDIT: Filled out a bug report at https://core.trac.wordpress.org/ticket/33617 Seems to be an issue with TinyMCE itself.

  • On your subdomain test install... it was still happening with the default WordPress theme and no plugins activated? – Will Aug 30 '15 at 16:40
  • I just tried it on two different 4.3 sites with your HTML and couldn't replicate it (in Firefox anyway). You might try filing a bug. They have some good 'before you file' steps for debugging that might be helpful too. – Will Aug 30 '15 at 16:56
  • Yeah, it was happening on a completely fresh install of WordPress with no plugins and running the stock theme. Could it be a related to my hosting provider? I'm gonna try install a local copy with XAMP to rule it out. Thanks for your feedback, I appreciate it. – Dan Aug 30 '15 at 20:00
  • It could be but it seems unlikely: it's a javascript error. Has it happened to you in more than one browser? If not, it could be a plugin in your browser. – Will Aug 30 '15 at 20:15
  • Yes, it's happening in all browsers that I have installed (Chrome, Firefox, Edge). Mozilla reports following error: too much recursion tinymce.min.js:7:18942 – Dan Aug 30 '15 at 20:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.