I migrated a WordPress 4.3 site from Register.com to MediaTemple today and found that the forced SSL is causing issues for the staging URL.

In order to try again I have (on the live Register.com site)

  • Disabled plugin 'WordPress HTTPS'
  • Removed define( 'FORCE_SSL_ADMIN', true ); from wp-config
  • In General Settings replaced https w http for URLs and saved
  • Saved permalinks just in case
  • verified that .htaccess is not redirecting to https via mod_rewrite

Tried logging out and accessing site and still get redirected from http to https.

Assuming my predecessor has not done anything truly crazy what am I missing there? Where should I look?

2 Answers 2


In the active theme I found the redirection in header.php

Once commented out the issue was resolved.

if($_SERVER["HTTPS"] != "on")
    header("Location: https://" . $_SERVER["HTTP_HOST"] . $_SERVER["REQUEST_URI"]);

I had the same issue after a migration on staging local environnent, I resolved it by emptying the cache with a hard refresh.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.