0

I tried to migrate my old blogs to a new server. The domain remained the same (it was also transfered to the new server). To perform this task I tried to follow these steps: https://codex.wordpress.org/Moving_WordPress#Keeping_Your_Domain_Name_and_URLs

When I now visit the moved blogs, I get nothing more than the "infamous white screen of death".

The wordpress version seems to be 4.1.2 The moved blog should be found at http://yeara.net/odysseus/ The old blog is at http://speendo.cassiopeia.uberspace.de/odysseus/

Can you help me to get this straight?

(X-post: https://wordpress.org/support/topic/server-migration-white-screen-of-death)

  • 1
    You appear to be outputting PHP. You should speak to your host. – vancoder Aug 17 '15 at 18:48
  • hm, this is my private server - I am my own host ... can you explain your assumption? – Marcel Aug 17 '15 at 18:51
  • 1
    Please provide debugging information, because a WSOD isn't very specific. – Nicolai Aug 17 '15 at 19:02
2

You may not have configured Apache. Add this line in your apache2.conf file:

AddType application/x-httpd-php .php .htm .html

Evidently, you should make sure you actually have installed and activated the PHP module first and foremost (the above Apache directive might not even be necessary in this case). In this regard, you can visit the /etc/apache2/mods-enabled/ folder and look for the php5.load, php5.conf files.

2

So your domain at yeara.net/odysseus loads the following in plain HTML:

<?php
/**
 * Front to the WordPress application. This file doesn't do anything, but loads
 * wp-blog-header.php which does and tells WordPress to load the theme.
 *
 * @package WordPress
 */

 /**
 * Tells WordPress to load the WordPress theme and output it.
 *
 * @var bool
 */
 define('WP_USE_THEMES', true);

 /** Loads the WordPress Environment and Template */
 require( dirname( __FILE__ ) . '/wp-blog-header.php' );

Have you confirmed that PHP is installed on your new server?

  • php is definitely installed. However, obviously the file does not get parsed. I try to find out why... – Marcel Aug 17 '15 at 19:14
  • In fact, php was installed and activated, however it was not enabled for the user directories. This can be done in /etc/apache2/mods-enabled/php5.conf. – Marcel Aug 18 '15 at 16:14
2

It might be a problem with file permissions, maybe related to the method you use for uploading the files, or as @webtoure pointed out with your apache set-up. The content @DaleAllen pointed out is the index.php of your WordPress installation. More critical I can see the content of your wp-config.php by directly pointing at it.

Take a look at the codex articles:

to change the file permissions accordingly.

Do NOT forget to change all security relevant information! Because if I can see it, everybody can.

  • 1
    @Marcel I can see the site. But you got some message about »Notice: wp_register_script was called incorrectly. (...)« that you should fix. – Nicolai Aug 17 '15 at 19:52
  • 1
    @Marcel It showed at the very top of your site. When viewing it xx minutes ago. Now the site doesn't load anymore, so whatever you did in the meantime broke it again. – Nicolai Aug 17 '15 at 20:17
  • 2
    @Marcel The server responds with an 500 Internal Server Error right now, it may be a faulty .htaccess involved. – webtoure Aug 17 '15 at 20:18
  • 1
    @Marcel Now I just feel bad. :( I am not helping here for points, I am here to interact with people and find solutions to problems (sort of like puzzles if you will). Please mark the best solution so that others can benefit from it and not because you feel somebody or somebody else deserves it. :) This is your right and privilege! :) – webtoure Aug 18 '15 at 16:39
  • 1
    @Marcel As said I'm fine with whatever - so all is good! – Nicolai Aug 18 '15 at 20:09
0

If the old blog and new blog have different domains then they didn't not remain the same. Share:

  • current exact URL to the home page is intended to be?
  • old exact URL to the home page was?

Without knowing more it seems like either a URL/directory issue or perhaps an issue with the files/database migration.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.