1

I've used a plugin called WP all-on-one migration to migrate my website. I've also saved the permalinks twice, as instructed after the importation.

The default permalink setting works fine, but any other permalink setting results in a 404 error code (except for the home page).

Plugin: https://wordpress.org/plugins/all-in-one-wp-migration/ Website: http://nieuw.ohmembercard.nl/

Already tried the following:
1. Saving the permalinks twice (as instructed after importing by the plugin)
2. Rename old .htaccess file, let the site automaticly create a new one

5
  • Probably best to check that the server can see the .htaccess file in the web root, easiest way to check quickly is to rename the one in the root of the web directory - change it to something like htaccess-old (remove the period '.' as well just to make sure) - then go back in and try and save your permalinks again, see if it creates a new .htaccess file.
    – Andy
    Aug 17, 2015 at 16:16
  • I've renamed the old htaccess file, and it autmaticly created a new one. The new one has the following code: ` # BEGIN WordPress <IfModule mod_rewrite.c> RewriteEngine On RewriteBase / RewriteRule ^index\.php$ - [L] RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule . /index.php [L] </IfModule> # END WordPress ` While the old one just has the START WordPress and END WordPress lines. But if i'm correct the lines starting with a # are comments in htaccess files? Aug 17, 2015 at 16:27
  • The new one looks better, and yes comments start with a #, don't remove them as they're read by the code to figure out where to put stuff if it's being autogenerated
    – Tom J Nowell
    Aug 17, 2015 at 16:30
  • Even though it created a new .htaccess file automaticly, the permalinks still aren't working. Aug 17, 2015 at 16:34
  • Does your server have mod_rewrite and is it configured to read the .htaccess file?
    – Milo
    Aug 17, 2015 at 17:05

1 Answer 1

0

I was migrating to Synology NAS.

Permalinks need .httaccess but this file is not used in Nginx server backend. So be sure that you have Apache server as backend when you are setting up your virtual host in the Webstation. WpAdmin will return you a success when you save permalinks but in fact nothing happen. Change to Appache and you are fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.