This is a common problem (so I've found out) but I cannot get WP to play nice with IIS 7.5 / PHP 5.6. Updating (WP + plugins) and installing (plugins) always return the error "Cannot create directory".

I am not using (nor can I use) FTP. The folders, include the temp folder all have full read/write access for the application pool identity and IUSR / IIS_IUSRS. I have tried all combinations of permissions and app pool identities to the point of exhaustion. I do not have Windows Cache Extension installed. I've tried this - How to update Wordpress installed on IIS? - I've even tried setting the app pool and site security to be the admin account on the server!!

What I'm looking for (very hopefully) is that single nugget of information, something to try, that I haven't found in the 3-4 days of Googling and messing around that I've done. I really hope somebody can help!!

1 Answer 1


IIS 7 creates "IUSR" as default user to access files via IIS. So make user IUSR has write access to files/folders.

How to check if IUSR has read Access?

Right Click -> Folder -> Properties -> Security Tab See if IUSR is in Group or user names list, If No.

Click Edit -> Add -> Advanced -> Find Now -> Select IUSR and click OK four times

Another way is AppPooling

->Open IIS Manager

-> Click the website you want to edit

-> Double-click Authentication

-> Click Anonymous Authentication, then click Edit... under Actions

-> Change to use the Application pool identity credentials instead of the Specific user (mine was IUSR)

Expect your issue will be fixed.

  • 2
    Have tried all of those things, as my question states. Commented Aug 21, 2015 at 16:03
  • 1
    add IIS_IUSRs and IUSR both users in access group and grand write permission Commented Aug 21, 2015 at 16:18
  • 2
    Did you not read this - "I've even tried setting the app pool and site security to be the admin account on the server" ? Commented Aug 21, 2015 at 16:32
  • I thought only the app pool had to run as a user with write access, but never new that Anonymous Authentication user would be used instead of the Application pool user.... Why actually? is it impersonating? I'm currently confused on what is running under which user. Any way, this finally worked. Only hope that it is also safe... Commented Dec 29, 2017 at 10:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.