0

I tried to install wordpress under eclipse and xampp under ubuntu. I created the database (user: root, password: empty) by a sql command create database wordpress;, that is it.

The wordpress seems to work, because I can run and see that with locallost under a browser.

Then, I tried to install another wordpress projet (which works) that my colleague had already customised. He sent me all the wordpress files and a database file asyc.sql. I created another projet under eclipse and imported the database by the following command line:

/opt/lampp/bin/mysql -u wpuser -p wpuser asyc < asyc.sql

And here is the result:

enter image description here

The database asyc does not seem to be well installed, though wp-config.php is well set in my opinion:

enter image description here

Does anyone know what is wrong?

0

Some things to check:

  1. Have you update the site URL in the wp_options table?
  2. Once you log-in to wp-admin change the permalink structure and click save - this makes the system refresh all the links.

I personally always use MySQL Workbench to Export and Import data for MySQL databases as it makes life much easier.

  • Thank you... I have done some tests and updated the OP... For your first question, the siteurl of wp_options is still http://localhost/wordpress (my initial projet). Is it normal that I cannot see the projet of my colleague (asyc) in phpmyadmin? For the second question, I cannot log-in to wp-admin of the projet of my colleague due to the database problem. – SoftTimur Aug 11 '15 at 13:57
  • 1
    So, the site URL should really be the new one [localhost/sun] or at least from your screenshots above that is what I would expect it to be. Secondly - you are right, you should see a database called 'asyc' in phpmyadmin. – Jonathan Taylor Aug 11 '15 at 14:07
  • So that means asyc.sql was not well imported... how should I import it? – SoftTimur Aug 11 '15 at 14:11
  • I'm not massively good with phpMyAdmin but from memory you have to click New above "information_schema" on the left. Create a new database called "asyc" etc. Select it on the left once you have done all that so it is "in use" - an import tab will appear where you can then upload your .sql file.... – Jonathan Taylor Aug 11 '15 at 14:16
  • I successfully imported the file (by Import button) by phpmyadmin, the site now works... thank you... – SoftTimur Aug 11 '15 at 14:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.