I have a custom taxonomy, really simple one. When inputing tag to the description it works fine and as expected. however when adding rel="nofollow" or rel=nofollow wp is dismissing the attr and save the a tag only with the href attr.

(the same for target=_blank)

any ideas?

BTW the auto XHTML flag in writing setting is off.

--Edit--

  1. registered new taxonomy:

    $labels = array(
    'name'                => _x( 'funders', 'taxonomy general name' ),
    'singular_name'       => _x( 'funder', 'taxonomy singular name' ),
    'search_items'        => __( 'search funder' ),
    'all_items'           => __( 'all funders' ),
    'parent_item'         => __( 'funder parent' ),
    'parent_item_colon'   => __( 'funder parent:' ),
    'edit_item'           => __( 'edit funder' ), 
    'update_item'         => __( 'update funder' ),
    'add_new_item'        => __( 'add funder' ),
    'new_item_name'       => __( 'funder name' ),
    'menu_name'           => __( 'Funder' )
    

    );
    $args = array( 'hierarchical' => true, 'labels' => $labels, 'show_ui' => true, 'show_admin_column' => true, 'show_in_nav_menus' => true, 'query_var' => true, 'rewrite' => array( 'slug' => 'funder' ) );

    register_taxonomy( 'funder', array( 'post' ), $args );

  2. added a term: name -> foo slug -> bar description-><a rel=nofollow target=_blank href="www.foo.com">bar</a>

  3. save

when viewing the term or edit it, I get: name -> foo slug -> bar description-><a href="www.foo.com">bar</a>

hope is clearer now.

  • nothing is clear to me and most probably others too.. – terminator Aug 10 '15 at 10:35
  • It is echoing as plain html in front end? Also, you are missing ending single quote in both 'funders' and 'funder'. EDIT: try escaping the "s <a href=\"##\" rel=\"nofollow\" target=\"_blank\">bar</a> – Abhik Aug 10 '15 at 11:06
  • the missing ending single quote is copy paste mistake, I have it in the original file. the echoing is not yet the problem, I can see that the attrs are dismissed in edit term page. tried to escape as well with no luck. – Meschiany Aug 10 '15 at 11:36

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.