1

I just bought and installed the WP-Facebook-AutoConnect plugin but I am unable to login.

Below is the debug log I got by email.


---LOG:---
Starting login process (Client: 178.156.161.15, Version: 2.0.4, Browser: Chrome 13.0.782.15 for Mac)
PREMIUM: Premium Addon Detected (#671, Version: 22)
WP: nonce check passed
WP: Found redirect URL (http://blog.i18n.ro/wp-admin/)
FB: Initiating Facebook connection via the new API...
FB: Connected to session (uid 685872843)
FB: Got user info (Sorin Ionuț Sbârnea)
FB: Email privilege granted, but only for an anonymous proxy address (apps+116692738389663.685872843.060155133d98d19b8fa5f9c49090e749@proxymail.facebook.com)
WP: Searching for user by meta...
FP: Searching for user by email hashes (8 candidates of 8 total users)...
   Checking Users #0-7
   WARNING: Could not register hashes with Facebook (connect_registerUsers generated an exception).  Hash lookup will cease here.
WP: No user found. Automatically registering (FB_685872843)
PREMIUM: Autoregistration is Disabled; redirecting to /.

---REQUEST:---
Array
(
   [redirectTo] => http://blog.i18n.ro/wp-admin/
   [rememberme] => 1
   [_wpnonce] => 3786067e30
   [_wp_http_referer] => /wp-login.php
)

2

Facebook's connect.registerUsers method is deprecated and doesn't work anymore.

Basically, the plugin is out of date.

| improve this answer | |
  • this wasn't true, see my answer. – sorin Jun 12 '11 at 8:28
  • It is true, as I know for a fact that the connect.registerUsers method doesn't work anymore. I had to remove it from SFC for this exact reason. – Otto Jun 15 '11 at 1:02
0

I used the premium plugin and I had to solve the following problems:

  • remove the application from facebook, because initially I allowed access to the proxied email address. Verifiy that your facebook account is a verified account before adding the application, otherwise the application will default to proxied emails instead of real ones.
  • checked the request real email address in plugin settings - be sure you press the right save button (there are several different ones on the page)
  • retried to login and when the permission popup appears you have to press the small change hyperlink under the email address permission and allow the application to access you real email address.
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.