0

I am stuck in .htaccess file creation for multisite. I am getting an error in page now internal error 500 and when i checked my log in apache it says C:/www/vhosts/localhost/wordpress3/.htaccess: RewriteEngine not allowed here. I allowed it in httpd.conf by removing the hash from LoadModule rewrite_module modules/mod_rewrite.so, still getting an error and it says page cannot be found. Can you please help me in this.

1
  • It helps if you phrase your title as a question. Also you might get more responses if you choose the answers that worked for your in your other questions.
    – Chris_O
    Commented Sep 19, 2010 at 23:02

1 Answer 1

1

You may need to set "AllowOverride All" in your apache config, for the Directory block for the server root, or root of your Wordpress install.

Here's what the relevant block looks like on a *nix system; things will probably look a little different on Windows:

<Directory /var/www/>
    Options Indexes FollowSymLinks MultiViews
AllowOverride All
Order allow,deny
allow from all
</Directory>

The AllowOverride tells Apache that .htaccess files are okay; without it, it will ignore the contents of any .htaccess files it finds.

hth,

~ Patch

3
  • Thanks, I did this but now I am not getting any error but i cant go to my admin section now, the admin page also redirects to the main page now :S
    – MsManiya
    Commented Sep 20, 2010 at 6:43
  • My super admin is created and i can make sites, but the root path is not showing any site now and is showing 404 forbidden error
    – MsManiya
    Commented Sep 20, 2010 at 12:23
  • You need to setup a different .htaccess file for a multi-site install than for a single site install. Try backing up the contents of you .htaccess file, removing the file, and then logging into the admin. There is a part of the config that gives you the .htaccess file to use; don't have it handy right at the moment.
    – Patch
    Commented Sep 25, 2010 at 16:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.