I have installed wordpress on one membership site and found that whenever editor writes post on wordpress and attempts to post it, deletes the half of post randomly. I don't know what could be the problem. I have already did my search within community forums here and here. These two threads explain the same problem that i'm having but none of the solutions are working for me. I also tried post revision plugins, sql query (for deletion of revisions), wp-config file modification and everything i could find on google. WP is just on spree of eating half the post no matter what.

Is there any solution for this ?

  • where is the code disappearing in single.php, are you using a loop.php file? have you checked your wp_post tables to see that the whole data is being saved into SQL? – MartinJJ Jun 10 '11 at 8:36
  • Not whole data is not being saved in wp-posts table. In fact i updated the post from phpmyadmin and that way it worked and from wp-dashboard it is not letting me revise the post. I have no clue from where text is disappearing, i'm using simple thematic theme inside membership site. – Mahesh Jun 10 '11 at 8:45
  • How large are these posts? How long are they? – Otto Jun 10 '11 at 16:39
  • 400 words or more. I don't think length has any issue with it. – Mahesh Jul 26 '11 at 7:20
  • any content losses half? say if you post 200 words you are left with 100? – Bainternet Jul 26 '11 at 8:25

Are you by any chance using special characters, such as accents?

Did you try to change the encoding of the server by using the .htaccess file?

php_value default_charset UTF-8 AddDefaultCharset UTF-8

Try replacing UTF-8 with iso-8859-1 or iso-8859-2.

EDIT: Are you posting double spaces? WordPress interprets these (in rare occasions) as a forced space, a non-breaking space (nbsp). Did you notice any pattern of deletion by using ampersands or other special characters?

Did you try to deactivate all plugins and set the default theme?

  • I removed the URF-8 in wordpress reading settings. To see if that works. But not working. I did noticed difference with special characters but removing encoding or replacing is not helping with it. – Mahesh Aug 26 '11 at 13:23

Try to verify if the problem is related to wordpress/mysql or simply to the PHP environment. Try to upload the following php script to your server, and view it with your browser. Paste some data, hit 'submit', and see if the output is truncated.

<pre><?php print_r($_POST);?></pre>
<form method="POST">
<textarea name="test"></textarea>
<input type="submit">

Also, try to run a php script with <?php phpinfo() ?> command, and see if there are any unusual restrictions in place, e.g. on the post_max_size.

  • I tried both of you ways to check for truncated output but there seems to be nothing wrong. By the way post_max_size is 64M. Is that right setting ? – Mahesh Aug 26 '11 at 13:45

The issue is related with the server permissions. I asked my hosts support to fix this. I found that they somehow fixed the issue. Also i noticed that ciprian's answer helped some of my friends but i was unable to solve issue that way.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.