0

I have a local install of wordpress

home page is accessible at http://localhost/activlist Backend is accessible at http://localhost/activlist/wp-admin etc

No other front end urls are accessible, they return 404

I have refreshed permalinks, and tested apache mod_rewrite is on with this script https://stackoverflow.com/questions/9021425/how-to-check-if-mod-rewrite-is-enabled-in-php

Any ideas?

  • Have you tried setting a different permalink structure, just to test? Have you checked your .htaccess file to ensure that WordPress's rewrite rules are there? Do you still get 404's if permalinks are turned off? – Matt van Andel Aug 2 '15 at 4:53
  • tried every different permalink setting and discovered it works on default localhost/activlist/?p=123 but not on any of the others. It seems to be anytime there is an entry in the custom structure input field then the pages and posts do not work. I have checked the .htaccess in the root directory and it seems to be correct, I can post it here if it helps. – lindsaymacvean Aug 2 '15 at 11:35
  • The custom structure /%category%/%postname%/ works fine on the remote server here... http://wuwoclientlindsay.wuwomedia.com/activelist_demo/activlist_providers/ – lindsaymacvean Aug 2 '15 at 11:38
  • have you checked that you have an .htaccess file in your wordpress root directory? – Mark Kaplun Aug 3 '15 at 6:02
0

Assuming you are on Linux, you need to make some changes in apache2.conf file stored in /etc/apache2 directory.

Open the file with root permissions, you will find the code given below in the file.

<Directory /var/www/>
    Options Indexes FollowSymLinks
    AllowOverride None
    Require all granted
</Directory>

Here just change the AllowOverride None to AllowOverride All, save the file & restart apache.

This will work in most of the cases.

  • This did the job, I initially was messing around with mod_rewrite but this was unnecessary as already loaded. Im on Fedora so my configuration file was stored at /etc/httpd/conf/httpd.conf Many thanks for your help. – lindsaymacvean Aug 7 '15 at 10:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.