1

My new permalinks continue displaying a 404 error on my site even after adding the AllowOverride and Rewrite modules parameters. Here is my default-ssl.conf file :

<IfModule mod_ssl.c>
<VirtualHost _default_:443>

    ServerAdmin vincent.zzz@gmail.com
    DocumentRoot /var/www/zzz
    ServerName zzz.com.vn
    ServerAlias www.zzz.com.vn

    <Directory "/var/www/zzz">
            Options Indexes FollowSymLinks MultiViews
            AllowOverride None
            Order allow,deny
            allow from all
    </Directory>

    <Location /> 
        <IfModule mod_rewrite.c>                            
            RewriteEngine on
            RewriteRule ^index\.php$ - [L]
            RewriteCond %{REQUEST_FILENAME} !-f
            RewriteCond %{REQUEST_FILENAME} !-d
            RewriteRule . /index.php [L]
        </IfModule>
    </Location>     


    #end of custon stuff..... 

</VirtualHost>

And here is the normal http part of my apache2.conf file :

<VirtualHost *:80>
    ServerName zzz.com.vn
    DocumentRoot /var/www/zzz
    <Directory "/var/www/zzz">

        Options FollowSymLinks
        AllowOverride All
        Order allow,deny
        Allow from all
        DirectoryIndex index.php

        #force SSL
        RewriteCond %{HTTPS} off
        RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R=permanent]

    </Directory>
</VirtualHost>

Would anyone have an idea ?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.