1

When I make click at any file from my website, the URL displays like:

www.mywebsite.com/index.php/about-me OR www.mywebsite.com/index.php/references

I just want to know if it is normal that index.php gets always displayed before any other file (something like www.mywebsite.com/about-me would be more common to see) or if this is some type of error.

1

First, check if you have an .htaccess file with the following:

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress

If this file already exists with the appropriate rules, try the following:

  • Go to your site Settings > Permalinks. If there is something already there, make sure you copy it and keep it safe in case it breaks your site. Select one of the defaults and save.
  • Visit your site and refresh.
  • If you still have no solution, try a hard refresh on your site - cmd/ctrl + shift + r.

If you are still having the problem, please go into more detail about the circumstances of your site (version, plugins, theme, etc.) so we can try to better help you.

  • Thank you very much! I will try to do this immediately. So, my site shouldn't display the index.php, right? – cp_miramar Jul 30 '15 at 20:56
  • Already fixed the the problem. Thank you for your suggestions. – cp_miramar Jul 30 '15 at 21:28
0

Thanks to the suggestions of @feelinferrety I was able to put the URLs from my website as www.mywebsite.com/index.php/about-me OR www.mywebsite.com/index.php/references. Just did the following:

Go to your site Settings > Permalinks > Common settings: Select the option Postname.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.