I created an additional site on my multisite subdomain installation. Now when I try to visit the new site or its wp-admin, I get a 404 error.

My wordpress instance is hosted on AWS

Checked the following

  • AllowOverride is set to All in httpd.conf
  • contents of .htaccess are the same as those in Network settings
  • added the necessary statements to wp-config.php
  • Tried restarting httpd as well

What else could I be doing wrong?


1 Answer 1


You need to set a wildcard serveralias in that site's virtualhost declaration. Right under where it says ServerName example.com you should add another line like this:

ServerAlias *.example.com

You might have already done that, but it was the only thing missing from the list of things you had checked.

  • No. I haven't added it. I don't see a <VirtualHost> tag in my httpd.conf. There isn't even a ServerName but I added it. When I add ServerAlias beneath it, it gives an error - ServerAlias only used in <VirtualHost> Commented Jun 9, 2011 at 14:56
  • So how do I add the ServerAlias? And will it cause any issues if I add a VirtualHost tag to my httpd.conf? When is it used? Commented Jun 9, 2011 at 14:57
  • What are the specs on your server (OS, version of Apache, etc)? Commented Jun 9, 2011 at 15:20
  • Generally, those things won't be in your httpd.conf file. They're usually in their own files so that they can be enabled and disabled. On my server (Ubuntu 11.04), the virtualhost files are in /etc/apache2/sites-available. Commented Jun 9, 2011 at 15:22
  • Hosted on AWS - Apache version 2.2.16 (Unix server) Commented Jun 9, 2011 at 19:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.