1

I have 2 virtual host for my wordpress blog. One handles the http port 80 request and other handles port 443 https requests.

I have added the following in my virtual host for port 80 to redirect all its request to https to make my blog available only on https.

RewriteRule ^(.*)$ https://%{HTTP_HOST}$1 [R=301,L]

Now when I tried to login into my admin account for wordpress it started to give me too many redirection issue while getting on the login page.

That was fixed by commenting out the SSL redirection code in the wp-login.php

But now after login when the link becomes

https://example.com/wp-admin/

Again I am getting same error.

So how can i possibily turn off the wp-admin redirects or add exception for wp-admin in my port 80 server rewrite command or and better way to redirect all traffic from http to https

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.