0

We were changing our wordpress site to use pretty links, but discovered that it broke old links. We tried to revert our changes, but whenever we open up /wp-admin/options-permalink.php (and only that page) we get a 500.0 internal server error. We run IIS 7.5 on Windows 7.

Error message

HTTP Error 500.0 - Internal Server Error
C:\Program Files (x86)\PHP\v5.4.36\php-cgi.exe - The FastCGI process exited unexpectedly
Detailed Error Information
Module  FastCgiModule
Notification    ExecuteRequestHandler
Handler php-5.4.36
Error Code  0x000000ff
Requested URL   http://gwswpp1svrus:80/wp-admin/options-permalink.php
Physical Path   E:\path\to\wp-admin\options-permalink.php
Logon Method    Anonymous
Logon User  Anonymous

When we run

C:\Program Files (x86)\PHP\v5.4.36\php-cgi.exe E:\path\to\wp-admin\options-permalink.php

we get a 302 response. We don't have a .htaccess file anywhere, nor is anything showing up in \wp-content\debug.log or our custom logging folder.

On our dev server we get the same issue, but only intermittently. Roughly every other page load will result in an equivalent 500 error. On both we've noticed rather substantial spikes in CPU load whenever the page is refreshed - up to 95%.

EDIT: We ended up experiencing the intermittent errors on prod as well, and managed to change the setting back, however we're still getting 500 errors on both dev and prod servers, with default permalinks.

Any help would be appreciated.

  • What is your MaxInstances and instanceMaxRequests in IIS? – czerspalace Jul 23 '15 at 23:02
  • @czerspalace neither of those show up when searching the configuration – Dannnno Jul 23 '15 at 23:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.