22

I'm having an issue with my admin menu in WordPress. As you can see in the image below the formatting of the menu is out of order. This happens whenever I first land on one of the admin pages but if I refresh the page the menu looks fine. I tried disabling my plugins but none of them seem to be causing the issue.

WordPress admin menu

  • 3
    Let me guess - you use Google Chrome as your browser. Try other browsers until Google fixes this problem. – Frank P. Walentynowicz Jul 22 '15 at 23:25
  • 2
    Yeah, it appears to be a Chrome issue. No problems in Firefox or IE. – brandozz Jul 23 '15 at 13:25
  • 1
    Yes, I'm seeing this too - only on Chrome. If you are the same as me, it has only started recently. Very annoying as Chrome is my browser of choice. I have found that if you collapse the menu then uncollapse, it is fine. But that's a pain to do. Might try to write some javascript to do this automatically on page load. – raffjones Aug 11 '15 at 13:07
  • 3
    This is an issue with Google Chrome. The current fix is to disable Slimming Paint as Otto42's Suggestion – Howdy_McGee Sep 3 '15 at 15:26
  • 1
    @trejder thanks for your contribution. My suggestion would indeed not have helped, and was merely a debugging suggestion, which is why it was not entered as an answer. However, there is no "frontend theme", there is only a theme, which can affect any aspect of WP, including admin. – vancoder Sep 10 '15 at 17:58
25

Otto has suggested a fix in Chrome itself until the bug is resolved:

  • Go to chrome://flags/#disable-slimming-paint
  • Enable the "Disable slimming paint" option.
  • Ensure that the "Enable slimming paint" option below it is not turned on.
  • Relaunch Chrome.

If you don't want to take this approach you can fix this with CSS:

function chromefix_inline_css()
{ 
  wp_add_inline_style( 'wp-admin', '#adminmenu { transform: translateZ(0); }' );
}

add_action('admin_enqueue_scripts', 'chromefix_inline_css');

If you just want a plugin to do it: https://github.com/raffjones/chrome-admin-menu-fix

  • 2
    This isn't the first time I've noticed odd graphical glitches in Chrome/webkit specifically either. In fact, jQuery developers have said "jQuery Core has more lines of fixes and patches for WebKit than any other browser. In general these are not recent regressions, but long-standing problems that have yet to be addressed." - cnet.com/news/… – NoBugs Sep 4 '15 at 4:04
  • Can there be any other reason for this issue? I have everything set, as you told and I'm still experiencing this issue on one of my computers (others has been successfully fixed with this fix). – trejder Sep 11 '15 at 19:11
  • 1
    From your screenshot, slimming paint is still enabled. I know it's a bit weird, but you need to "enable" the Disable Slimming Paint feature and relaunch Chrome. Click the "Enable" link under the setting. – raffjones Sep 11 '15 at 23:38
  • 2
    This has been resolved in the latest version of Chrome Canary. Google are saying it will be out in the stable branch in about a week. See this link – raffjones Sep 12 '15 at 8:35

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.