am running the CFT plugin version 1.9.2 on a 3.1.3 wordpress site and in the admin i did set up 30 input file fields related to a custom post type. It all works fine until the 21st field (and beyond) that does not save any file (small picture) that is selected.

I did a local test on wamp, and it all works fine, all the 30 fields are saving (and displaying) well the pictures.

I did another test online (different server) on a test installation. I uploaded the database used locally and all the files, checked the site and the post is displaying well the pictures: link and has obviously all 30 saved in the admin.

So after that i tried to create a new post on this test site and uploaded the pictures from the admin and bam there goes the same problem, stuck at 20: link.

The media upload works fine by the admin works fine, even with high res pics.

Here's the beginning of my template's content in the CFT admin:

type = textarea
label = Introdução
cols = 50
rows = 6

type = file
label = Imagem projeto #1 (capa)

type = file
label = Imagem projeto #2

type = file
label = Imagem projeto #3

I also tried to add the blank = true to my type= file fields but didnt seem to help.

I'd be glad to have your point of view on this cos am stuck. Thanks in advance.

  • Seems like it's a php configuration setting "max_file_uploads" rather than a wp problem. Support says i gotta add " ini_set (max_file_upload, xxx )" at the beginning of my script. Question is, where is this script? And is there a way to add this within the functions.php theme file?
    – kevin
    Commented Jun 9, 2011 at 14:06

2 Answers 2


Found a solution. I divided my pictures into 3 templates and in the post admin i just have to load them with the drop-down menu. The value of "max_file_uploads" is still stuck at 20 but for now it's the best solution i found.


Update, just got the problem back and found a 'real solution, to update the php.ini file at the root of the site with this: max_file_uploads = 100

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.