If i try to access my wordpress page using the native url structure i.e. for instance:


I am redirected to my homepage. It doesn't seem to be an htaccess issue for I tried without it as well. This is also causing some of the ajax requests to fail. It works fine if I go back to the default url scheme.

migrated from stackoverflow.com Jun 7 '11 at 13:19

This question came from our site for professional and enthusiast programmers.

  • Do you have this problem with one specific theme? If so, there's probably something in your theme's index.php or functions.php file that prevents the redirect. – Jules Jun 6 '11 at 13:40
  • hey, thanks, I would check it out...the problem occurs only on live, things are fine locally and this issue first appeared around the time we updated our wordpress to 3.1.2. Also worth mentioning is that its working fine if I use: www.mywebsite.com/index.php?p=123 instead of: www.mywebsite.com/?p=123 – Uzair Khan Jun 7 '11 at 5:40

I think the problem comes from the rewrite rules that had been saved when you developed the site locally. To fix it, you should go to Settings -> Permalinks and set the permalink structure again. Note that, you may just click on the save button, that will flush the rewrite rules for you.

  • Well, it wasn't an htaccess issue. The problem was that our server guys were displaying a cached html page instead of serving the default index.php and that resulted in the arguments being ignored :/ Still, thanks for the help guys. – Uzair Khan Jun 23 '11 at 9:21
  • @UzairKhan you should post your comment as an answer, and accept it. – Chip Bennett Oct 17 '11 at 18:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.