0

Whenever I try to add new posts or pages, or edit posts or pages from the admin menu, from the front end or even from the all posts and all pages lists, I can't. I'm always taken to a 404 error page.

How can I fix this?

  • Wordpress was installed in English, installing in Spanish results in same issue.
  • Database is UTF-8,
  • PERMALINKS ARE NOT THE ISSUE (I've set and reset them to try and fix as I've seen other people claim this works for them),
  • I have already tried the "Disable all Plugins" and before I got to the "Try one by one to find which one is the problem", the error is still there.
  • .htaccess is fine, it's editable and has the proper modrewrite code

my site is http://cocodrilo.com.bo

0

It's possible this is a permissions error, relating to a incorrect permissions for a particular fine used in post editing.

Have you tried setting correct permissions for your WP install?

Here's a bit of further documentation:

https://codex.wordpress.org/Changing_File_Permissions

  • Yes but permissions for what file or folder? – Pablo Alvestegui Jul 3 '15 at 0:00
  • It's generally recommended to set correct permissions for every file and folder in your WP install. – performadigital Jul 3 '15 at 6:29
  • Thank you! Performadigital. I don't know what I would do without your help. Wait! Could you suggest, at a certain level of approximation, which particular files I should identify for permission correction? – Pablo Alvestegui Jul 8 '15 at 14:10
  • It's not so much about setting individual files really. It's important to ensure all file permissions (and ownership) are correctly set and if not then all kinds of issues can arise, from a site failing to load completely to just a small function not working correctly. This link should explain this further and see the section 'What Permissions Should I Use'. The easiest way to set file permissions in bulk is to use SSH and run commands (google Set permissions via SSH for more on this), alternatively it can be done via FTP but takes a bit more time to go through everything. – performadigital Jul 9 '15 at 0:05
  • The exact single file most likely relating your issue is wp-admin/post.php but it's still recommended to ensure all permissions are set correctly as it may not be that specific file causing the issue. – performadigital Jul 9 '15 at 0:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.