0

When I Import Mysql from local server to web ser it is showng me error

1115 - Unknown character set: 'utf8mb4' in Creating wordpress wp_comment table

CREATE TABLE IF NOT EXISTS  `wp_commentmeta` (
//
//
) ENGINE = INNODB DEFAULT CHARSET = utf8mb4 AUTO_INCREMENT =1;
 #1115 - Unknown character set: 'utf8mb4'

My mysql version is

Version information: 4.0.4, latest stable version: 4.4.10 (local version)

Version information: 4.0.10.7, latest stable version: 4.4.10( server version)

Please help me to solve out the error

  • 2
    Either update your server's (frankly ancient) MySQL to 5.5.3 (at least) or edit the import file, replacing all instances of utf8mb4 with utf8. – bonger Jun 29 '15 at 12:16
  • How do you create your import file? If you use phpMyAdmin then replace compatibility mode NONE ( default ) with MYSQL40. No manual editing of the resulting file will be necessary. If you use a database backup plugin which does not support compatibilty modes then find the call to mysqldump command and add --compatible=mysql40 parameter to it. – Frank P. Walentynowicz Jun 29 '15 at 21:08
  • Of note, utf8mb4 was introduced to fix security issues and introduce support for emoji – Tom J Nowell Oct 26 '15 at 14:14
4

WordPress does not support MySQL 4 :

To run WordPress your host just needs a couple of things:

MySQL version 5.0 or greater (recommended: MySQL 5.5 or greater)

https://wordpress.org/about/requirements/

While the utf8mb4 encoding is recent change and you might work around it, overall you still need compatible MySQL version.

0

From stackoverflow.com

Your version does not support that character set, I believe it was 5.5.3 that introduced it. You should upgrade your mysql to the version you used to export this file.

The error is then quite clear: you set a certain character set in your code, but your mysql version does not support it, and therefore does not know about it.

According to https://dev.mysql.com/doc/refman/5.5/en/charset-unicode-utf8mb4.html :

utf8mb4 is a superset of utf8

so maybe there is a chance you can just make it utf8, close your eyes and hope, but that would depend on your data, and I'd not recommend it.

-3

simply open your exported database in a text editor and replace all utf8mb4 with utf8 and export after. just be critical to choose the right character set when exporting databases.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.