0

I am currently using WordPress 4.2.2 and Woocommerce 2.3.11 -

I find that many plugins associated with Woocommerce have not yet been updated for whatever reason. In some cases a whole year has gone by with no updates to the plugins.

  • Would it be advisable to regress to an older version of Wordpress?
  • Is there a recommendable version to go back to? Say WordPress 4.0/4.1/4.2?

I understand that it may depend on my current situation. Most of the plugins i need to use are compatible to v4.1.5 only.

  • Is it advisable(a good/safe idea) to use WordPress 4.0/4.1?

I am concerned about the security problems(if any) if i use and older version.

closed as primarily opinion-based by TheDeadMedic, Pieter Goosen, Robert hue, Howdy_McGee, Brad Dalton Jul 8 '15 at 1:31

Many good questions generate some degree of opinion based on expert experience, but answers to this question will tend to be almost entirely based on opinions, rather than facts, references, or specific expertise. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    No one is going to recommend running anything other than the latest version of WordPress, do so at your own risk. Contact the plugin authors and politely ask them to update their code. – TheDeadMedic Jun 26 '15 at 10:59
  • Agreed with @TheDeadMedic Run older versions of Wordpress at your risk. – Pieter Goosen Jun 26 '15 at 11:54
0

It is not advisable to run anything but the latest wordpress, especially with regards to security fixes. For a minior wordpress release, you can read the release notes and see if any of the changes are security related. If they aren't, then you can probably safely wait until the next security fix.

In my experience, wordpress updates only sometimes break a plugin. The problem, though, is that if there is a security fix in an update, it is quite irresponsible to not apply the update, especially if you have sensitive data in your system. This is just the burden of modern software, updates are mostly required, but the ofter cause incompatibilities.

A good solution is to set up a staging environment for yourself to see if the update breaks any plugins. If it doesn't, apply the update, if it does, start working on a contingency plan.

Good luck,

  • Very interesting! Thank you for your kind feedback @JJ Rohrer, much appreciated! – Kbam7 Jun 27 '15 at 11:58

Not the answer you're looking for? Browse other questions tagged or ask your own question.