1

The problem began with the wp upgrade redirect loop

I tried to fix it by renaming one of the table value fors wp_options on php admin

As a result of this I cannot log into my site anymore ..it gives the redirect loop. Furthermore, there is a bunch of gibberish all over my site with error messages hen I try to debug.

Here is what the debug says:

WordPress database error: [Can't create/write to file '/tmp/#sql_f944c_0.MAI' (Errcode: 13 "Permission denied")]
SHOW FULL COLUMNS FROM `wp_options`
WordPress database error: [Can't create/write to file '/tmp/#sql_f944c_0.MAI' (Errcode: 13 "Permission denied")]
SELECT t.*, tt.*, tr.object_id FROM wp_terms AS t INNER JOIN wp_term_taxonomy AS tt ON tt.term_id = t.term_id INNER JOIN wp_term_relationships AS tr ON tr.term_taxonomy_id = tt.term_taxonomy_id WHERE tt.taxonomy IN ('category', 'post_tag', 'post_format') AND tr.object_id IN (3165) ORDER BY t.name ASC

I have no idea where to begin to fix this. I have database backups but I don't know which files are messed up.

Is there a way to put up a simple static html page on top of my index.php page without affecting the rest of the site? I need to alert readers that my site is malfunctioning and show them a link to a new version while I try to fix the old version.

I can't login , can't post..cant do anything

5
  • What did you rename? – s_ha_dum Jun 13 '15 at 3:21
  • wp_optons in phpmyadmin Now my entire site is bank. I backed up the database but the restored versions still are blank. all the folders don;t work and show as blank pages that take 5 minutes to load. Only the index page loads normally but nothing else does. Wordpress sucks – Thomas Baert Jun 13 '15 at 4:09
  • You renamed the whole table? – s_ha_dum Jun 13 '15 at 15:12
  • 2
    Renaming wp_options to wp_optons is like turning the frontal lobe of your brain into a puffer fish when you have a stupid moment, in the hopes that it'll grow a smarter frontal lobe as a replacement. Rename it back to wp_options and focus on your original problem instead. Any information you can provide about how your site is setup would be great, e.g. is it a multisite install, subdomain or subdirectory, you're upgrading from v? to v? etc – Tom J Nowell Jun 13 '15 at 15:15
  • Lol @TomJNowell the pufferfish brain expert. To get back to point, you should not make any changes to a live install unless you have thourougly tested your proposed changes on a local test installation. Note, your local install and live install should be set up the same to avoid compatibility problems – Pieter Goosen Jun 14 '15 at 18:52
1

After 6 hours of trial and error, I deleted my site, uploaded an older version of wordpress, made a new database, re-named the plugin folder (so that there would be no plugins), and uploaded my most recent database back-up..and then it worked. I was able to login and all my page were restored. The problem may have been the plugin file, or my host, or my version of wordpress causing problems.

1

As you can see from the error itself (Can't create/write to file '/tmp/#sql_f944c_0.MAI' (Errcode: 13 "Permission denied") this is a system issue. Your mysql instance cannot write to the linux /tmp directory because either the disk is full or the mysqld process has no security permissions to write to tmp.

If you are self-hosting Wordpress on a server you have ssh access to you should take a look at the mysql configuration (usually /etc/my.cnf) and find what is declared as tmpdir (cat /etc/my.cnf | grep tmpdir). It should be /tmp, and again the permissions for /tmp should be set as follows: chmod 1777 /tmp.

If your Wordpress is not self-hosted I suggest to contact your hosting provider to find out what's happening.

0

Have you tried creating a new database, upload your backup to it - then redirect wordpress to use this instead?

In the meantime you could create a basic html document in your root folder then use .htaccess to redirect when ever anyone without your ip address enters site

Add this to your .htaccess file and change the ip address to yours and the newhtmlfile name to the one you created

RewriteEngine on
RewriteCond %{REMOTE_ADDR} !=xxx.xxx.xxx.xxx
RewriteRule index.php$ /newhtmlfile.php [R=301,L]

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.