1

My php script to post new content via xmlrpc to remote blogs occasionally fails due to the dreaded transport error. Usually I just end up manually posting this content, but now I'm trying to debug the issue. Should note that the script works fine 98% of the time.

I've managed to narrow down the issue to the post_content field itself. Tested for post length, existence of html tags, etc. Also tested using substrings of full post content. Seems that the script fails on a random letter around the 1130th character. Yet if I generate a lorem ipsum post with more characters this works fine.

Encoding is UTF-8, and I'm not seeing any invalid XML characters.

Have tried htmlentities, htmlspecialchars, and everything else without any luck. Even tried to retype the post content where it fails, but that didn't work either.

Any other troubleshooting ideas? Unfortunately I don't have access to the logs for the remote server which would make it easier of course.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.