1

When I deactivate w3 total cache my feed is not minify. But when I bring it back it does. Even when I uncheck: Cache feeds: site, categories, tags, comments. In Page Cache setting of the plugin.

Is there something else I am missing here?

1
  • 1
    I'm not sure what you're asking, if W3 is minifying your feeds, and you deactive W3, then your feed won't be minified. If you want W3 but don't want your feed minified, you should contact W3 support
    – Tom J Nowell
    Jun 6 '15 at 0:18
2

To stop W3 Total Cache from minifying the feeds you need to go to:

  1. In the menu: Performance > Minify
  2. Meta Box: HTML & XML > HTML minify settings:
  3. Check the box for: Don't minify feeds

One of the issues with feed minifying is that it adds CDATA wrapper around javascript in the content and that breaks the XML. I had this issue with videos that were in my content that used javascript.

Here is a screenshot that might help:

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.