I have a Linode VPS running a single Wordpress blog. It has been running just fine until today. The admin panel is snappy, but the site is very slow. I am still finishing the site, so there shouldn't be any traffic.

When I go to mydomain.com it takes 45+ seconds to load, then each click on the link takes about the same amount of time. I didn't update any WP plugins (or WP), but I did add a google analytics plugin a week ago, but seemed fine. I disabled that and no difference either.

I tried rebooting nginx, and then rebooted the whole machine... still slow. My "free -m" output is:

 user@myserver~ $ free -m
         total       used       free     shared    buffers     cached
 Mem:     469        147        321          0          3         45
 -/+ buffers/cache:   98        370
 Swap:    511          0        511

The weird part is nothing has changed in the last few days....Any ideas?

1 Answer 1


Not much information to go on... Start with elimination - disable the plugins, switch to default (or better - blank) theme. If it gets better - just find code at fault. If you are down to the bare and clean WP core and still having the issue - likely you have some server configuration issue.

Since you have considerable control over server you can also hook up some PHP profiler and try to make a dump of what is going on.

  • I did what you suggested, and it seems to be resolved once I switch themes to twenty ten. I also recovered my Linode to 3 days ago and it seems to have the same problem. Now i'm thoroughly confused because it ran like a top 3 days ago... Jun 2, 2011 at 2:07
  • @SkinnyGeek101 well, now you have a better guess where the issue is. I'd hook up xdebug or xhprof and generate performance dump.
    – Rarst
    Jun 2, 2011 at 8:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.