0

Any reason why the ability to toggle between Visual and Text stops working? In fact, all tabs stop working from time to time. This doesn't happen site wide, only a couple pages. It seems to happen on text/code heavy pages.I can only edit in text mode.

Screen Options, Help, Revisions, all tabs are inactive at times. Sometimes reloading the page works.

Any suggestions? Thanks

  • 1
    check your browser's javascript console for errors. – Milo May 18 '15 at 21:24
1

If I am right, a plugin might be causing the issue.

To detect the cause of problem, you must know when did this problem started occuring? Did you start after you upgraded WordPress, or after you activated a certain plugin?

Also if you're using WordPress version 3.5, that version does have this issue. Check here, it should have been fixed in 3.5.1.

What next?

Well, I will suggest you to upgrade the version if you've not already and/or try deactivating plugins one by one and checking if problem got solved.

0

I had the same problem. The cause of problem was qtranslate plugin, which is not more supported but we use it for translates. We had 2 options change plugin or try to rewrite plugin. But i found the another solution. Client need use Visual so you can in function.php choose defualt editor html = text or tinymce = visual. So here is hook i hope it could help u :

add_filter( 'wp_default_editor', create_function('', 'return "tinymce";') );
-1

Found the issue… I think wordpress will find a lasting solution to it soon ..

but in the main time this will help .. its quite easy

For now, open this file:

wp-content/plugins/gp-premium/sections/functions/metaboxes/js/generate-sections-metabox.js

Find:

tinyMCEPreInit.qtInit["generate-sections-editor"] = this.qt_settings;

And replace it with:

tinyMCEPreInit.qtInit[“generate-sections-editor”] = this.qt_settings; tinyMCEPreInit.mceInit[“generate-sections-editor”].wp_keep_scroll_position = false;

Source : http://www.350ng.com/2018/10/14/4-9-tinymce-issues-solution/

  • Modifying plugins code is a very bad idea. Your changes will be lost after update and you may break anything. If there is a change needed in plugin, then notify its author. Especially if this is a premium plugin... – Krzysiek Dróżdż Oct 14 '18 at 8:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.