1

I have had a requirement to update a WP build so that the thumbnail size changes from (the default) 150x150 to 500x500.

I've amended the size within the Settings > Media and utilised the awesome "Regenerate Thumbnails" plug-in to create the image files at the new sizes. So everything should be cool... alas not!

When I call my new image thumbnail wp_get_attachment_image_src( get_post_thumbnail_id(get_the_ID()),'thumbnail'); Wordpress is still returning my image as ...150x150.jpg and not the new thumbnail size.

I've attempted updating the page/post in which the image appears but this doesn't seem to work. Any ideas?

Note: I am using a multi-site instance of Wordpress, but I've checked each instance to ensure that the images have been resized and that the settings have updated. Everything seems to be working correctly.

  • You should resize all your images after you changed the settings. wordpress.org/plugins/bulk-resize-media – user40422 May 7 '15 at 9:44
  • Yeah I did that... I have all of the images in the correct sizes, it just seems that WP still believes the 'thumbnail' size is the default. – Sheixt May 7 '15 at 10:38
-1
wp_get_attachment_image_src( get_post_thumbnail_id( get_the_ID() ), 'medium' );
  • 2
    Please add an explanation to what your code does and how it should be used. Dumping code is not a quality answer if it even considred to be an answer – Pieter Goosen May 7 '15 at 9:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.