I've just installed a fresh WordPress setup on Windows Server 2008 Web R2 (IIS7) with SQL Server Express and WordPress 3.1.

I completed the install successfully and logged into the admin section to start the activation of the WordPress network (using sub-domains). Having edited the wp-config file, I added the code WordPress generated to both wp-config (Network specific) and web.config (Rewrites).

Since adding these changes, each time I try to login to WordPress, I just get loop'd straight back to the login page. I've tried to following so far:

  1. Comment out the network specific changes in wp-config and revert the rewrite rules to standard WordPress ones (Didn't work).
  2. Checked IIS Admin for any re-writes already in place (None)

Details of wp-config and web.config below:

define('WP_ALLOW_MULTISITE', true);

define( 'MULTISITE', true );
define( 'SUBDOMAIN_INSTALL', true );
$base = '/';
define( 'DOMAIN_CURRENT_SITE', 'svr-web-csrms' );
define( 'PATH_CURRENT_SITE', '/' );
define( 'SITE_ID_CURRENT_SITE', 1 );
define( 'BLOG_ID_CURRENT_SITE', 1 );

web.config: http://pastebin.com/8xctXizE

Update: I have had a thought. From reading this here:

Note that per the Settings Requirements you cannot switch from Sub-folder to Sub-domain >when running on or localhost. This can potentially cause an endless loop of >reauth=1 on your root site due to cookie handling.

I may have an issue due to the fact I am using an internal address. I'll set WordPress up with a proper domain and come back.

  • Any progress? Could you resolve the issue? If so, please add your solution as answer and mark the question as answered.
    – fuxia
    Commented Feb 16, 2012 at 22:03

1 Answer 1


This sounds like your domain doesn't match the cookie being generated. It may not have anything to do with the IP.

define( 'DOMAIN_CURRENT_SITE', 'svr-web-csrms' );

I would expect an actual domain or something, like this.

define( 'DOMAIN_CURRENT_SITE', 'subdomain.mysite.tld' );

I tried to look at your web.config - but it appears that the URL is now broken.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.