1

I installed WordPress on a dedicated server running Debian and each time a create a new page (www.mydomain.com/mynewpage) I can't access it, and when I try I get the error:

Not Found

The requested URL /mynewpage was not found on this server.

Even when I modify it in the WP admin board, If I click "Preview the changes", I get this error. The only page working is www.mydomain.com

Could anyone please help me ?

Thanks for your help

Matthias

  • Is mod_rewrite enabled on the new server? I would bet it is not by default. WP requires this for permalinks. Ck a phpinfo() result to confirm. – jdm2112 May 5 '15 at 17:47
  • I guess I have to look in the 'Loaded modules'in phpinfo() section, so I have: core mod_log_config mod_logio mod_version prefork http_core mod_so mod_alias mod_auth_basic mod_authn_file mod_authz_default mod_authz_groupfile mod_authz_host mod_authz_user mod_autoindex mod_cgi mod_deflate mod_dir mod_env mod_mime mod_negotiation mod_instaweb mod_php5 mod_reqtimeout mod_setenvif mod_status How do I activate mod_rewrite ? – Graham Slick May 5 '15 at 18:05
  • google.com/… – jdm2112 May 5 '15 at 18:08
2

After checking phpinfo(), mod_rewrite wasn't enabled so I enabled it:

http://linuxcommando.blogspot.fr/2014/03/how-to-enable-modrewrite-for-apache-web.html

and it worked !

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.