2

I am currently using a wordpress installation in which all the website is intended to be shown in http while the https part is protected by a self signed certificate, distributed manually to the admins. The problem I have is that the images uploaded are all uploaded with the "https" prefix, I imagine because the link is generated somehow using the full path of the admin interface. Do you know how I can fix this behaviour to use the protocol http for every image uploaded? I don't really need https for this and the site name and URL is in http.

Thanks in advance.

Some specs:

  • wordpress version: 4.2.1
  • plugins installed: Category Posts Widget, Jetpack, Post Types Order, Relative Image URLs, WordPress SEO, WP Statistics.
  • Do you have http or https under "Settings" -> URL? If you have https all urls will be saved with https. – gdaniel May 4 '15 at 21:09
  • I got all http, that's the strange thing. – Raffo May 4 '15 at 21:54
0

My advice is to make the whole site https. Either add https to the settings -> wordpress address & settings -> site address or remove https if it appears in either of those inputs.

For securing admin login panel only:

  1. easy method but doesn't show secure icon.
  2. right result but more steps to consider method.
  • I just wanted to skip the CA as I have only one admin and few users. – Raffo May 4 '15 at 21:55
  • I'm still unsure why you want to use https to the admins only. Are you just wanting https for the login pages or the entire wp-admin panel? – Caleuanhopkins May 4 '15 at 21:57
  • I just need it for the login, but currently the whole wp-admin panel is in https. – Raffo May 4 '15 at 22:00
  • @Raffo have updated my answer with links to discussions and posted solutions for securing the admin login panel only. – Caleuanhopkins May 4 '15 at 22:09
0

I figured out the problem: the SEO plugin by Yoast is breaking the images as described, doing (probably) a URL rewrite at the time the media is upload. I resolved temporarily bye disabling the plugin. I will then find a better solution analyzing why the plugin is behaving in such a way and update my answer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.