I recently noticed something displaying on my html source. Here are they.

<!-- This site is optimized with the Yoast WordPress SEO plugin v2.1.1 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="robots" content="noindex,follow"/>
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","url":"https:\/\/kl.ncc.my\/","name":"NCC KL \/ Selangor"}</script>
<!-- / Yoast WordPress SEO plugin. -->

        <script type="text/javascript">
            window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/72x72\/","ext":".png","source":{"concatemoji":"https:\/\/kl.ncc.my\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.2.1"}};
            !function(a,b,c){function d(a){var c=b.createElement("canvas"),d=c.getContext&&c.getContext("2d");return d&&d.fillText?(d.textBaseline="top",d.font="600 32px Arial","flag"===a?(d.fillText(String.fromCharCode(55356,56812,55356,56807),0,0),c.toDataURL().length>3e3):(d.fillText(String.fromCharCode(55357,56835),0,0),0!==d.getImageData(16,16,1,1).data[0])):!1}function e(a){var c=b.createElement("script");c.src=a,c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f;c.supports={simple:d("simple"),flag:d("flag")},c.supports.simple&&c.supports.flag||(f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
        <style type="text/css">
img.emoji {
    display: inline !important;
    border: none !important;
    box-shadow: none !important;
    height: 1em !important;
    width: 1em !important;
    margin: 0 .07em !important;
    vertical-align: -0.1em !important;
    background: none !important;
    padding: 0 !important;

I have checked all my plugins, i find no where to delete them. Does someone here facing same issue? I just want the robot meta tag to display. Just to delete the rest of coding above. Any solutions?

  • Hi Peter Goosen, the emoji issue has been resolved. Just the schema coding yet to remove. Do you think, it's good to have schema generator? – Jornes Apr 30 '15 at 6:22

Emoji is a new feature added to WordPress 4.2 core and has nothing to do with your WP SEO code. You can remove these by using this removing action in functions.php

Code Update - Christine Cooper's answer here: Disable Emojis deals with all Emoji content throughout the site.

function disable_wp_emojicons() {
  // all actions related to emojis
  remove_action( 'admin_print_styles', 'print_emoji_styles' );
  remove_action( 'wp_head', 'print_emoji_detection_script', 7 );
  remove_action( 'admin_print_scripts', 'print_emoji_detection_script' );
  remove_action( 'wp_print_styles', 'print_emoji_styles' );
  remove_filter( 'wp_mail', 'wp_staticize_emoji_for_email' );
  remove_filter( 'the_content_feed', 'wp_staticize_emoji' );
  remove_filter( 'comment_text_rss', 'wp_staticize_emoji' );

// filter to remove TinyMCE emojis
add_filter( 'tiny_mce_plugins', 'disable_emojicons_tinymce' );
add_action( 'init', 'disable_wp_emojicons' );

or use this plugin: Disable Emojis

  • Thanks Manoj Kumar! How about this line? – Jornes Apr 29 '15 at 2:42
  • <script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","url":"https:\/\/kl.ncc.my\/","name":"NCC KL \/ Selangor"}</script> – Jornes Apr 29 '15 at 2:43
  • Looks like you are using a schema generator plugin. Try to disable the plugin that is generating it. It could be a option in WP SEO Yoast as well. If kl.cc.my is one of your sites, then I don't see it as a unwanted code. – m4n0 Apr 29 '15 at 2:56
  • I'm not using and didn't install the schema generator. I have been searching for the option where to disable it but failed to do so. No way to find. Do you know any? – Jornes Apr 29 '15 at 3:15
  • Jornes, It is really good to have schema generator which is used by the search engine bots. More here: Schema Generator – m4n0 Apr 30 '15 at 7:47

Not the answer you're looking for? Browse other questions tagged or ask your own question.