1

Site owner updated her multisite yesterday via the dashboard. The site itself is still running, but the network and primary site dashboard both return a 500 error. However, the wp-admin for two subdomain sites can be accessed just fine.

The related PHP errors showing up are these:

[Mon Apr 27 23:36:21 2015] [warn] [client x.x.x.x] mod_fcgid: read data timeout in 45 seconds

[Mon Apr 27 23:36:21 2015] [error] [client x.x.x.x] Premature end of script headers: update-core.php

Anyone seen this or have any idea?

  • I should mention that I have tried disabling all plugins and changing the twentyfifteen but still getting the same issue. – John Chandler Apr 29 '15 at 1:01
  • Another update: after rolling the site back to a 4.1.4, everything works again. Ran another automatic update from there and it broke again. – John Chandler Apr 29 '15 at 2:23
  • Isn't your issue solved - wordpress.org/support/topic/… ? – denis.stoyanov Feb 27 '16 at 13:28
1

based on https://wordpress.org/support/topic/wp-admin-returning-500-errors-after-update-to-421, seems like it was related to the conversions of tables to utf8mb format done in 4.2 which timeout when there are many comment.

Possible solutions: make the DB upgrade on some staging server in which all timeouts are off, or increase the timeout on the production server until it works.

-1

Delete the .htaccess in wordpress root should bring site back up reset permalinks admin - settings - permalinks. If you don't see the htaccess file it is likely hidden you have to select show hidden files in whatever method you use to view files

  • Unfortunately, not a fix. I had already tried that but tried it again just because. – John Chandler Apr 29 '15 at 1:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.