1

I've followed the instructions here on how to configure wildcard subdomains for my multisite setup on Plesk but can't quite get it to work. Everything functions as it should in the backend: I can create a new site and it get's added correctly to the database, but I can't access the admin area. If I visit the home page for the new site I get the Parallels default holding page but the site admin returns a 404.

Can anyone recommend how I might test to find out at which point my setup is not configured correctly? Here's step by step the procedure I've followed.

  1. Set the Domain wildcard subdomains in Apache /var/www/vhosts/domain.com/conf/vhost.conf Add a single line - ServerAlias *.yourdomain.com - to the start of the file. Save the vhost.conf file and restart Apache

  2. Create wildcard CNAME record in DNS for domain using *.example.com CNAME example.com as the parameters rebuild the vhosts config using

  3. Log into your site, go to the home site Administration Panel - Settings - Permalinks - and save them again

NB: Although the linked article talks about retaining webmail for the additional sites this is not a requirement of my setup.

I know a (very) little command line so please be gentle.

  • what version of plesk? – Guerrilla Apr 28 '15 at 13:09
  • Hi @Guerrilla, thanks for your reply. I'm running version 12.0.18 of Plesk. – Kevin Nugent Apr 29 '15 at 8:14
1

You have forwarded the wildcards to the wrong subdirectory this is why you are seeing the Plesk default page. The wildcard subdomain rule should point to the folder of your wordpress multisite installation.

Wordpress reads the URL from the request and then internally routes to the correct site. If it's not pointed to right place then this can't happen.

I think this probably means the CNAME is done correctly but you do not have the DNS entry set up.

  • So I've set the rule in vhost.conf to 'ServerAlias *.yourdomain.com', do you think this should point to the folder httpdocs? This is the root folder for this domain, I'm not running WP out of a another, deeper sub folder. – Kevin Nugent Apr 29 '15 at 8:17
  • Did you notice on WP page that it says to use quotes on version 10? ServerAlias "*.yourdomain.com". It might be the same for version 12. It also might be that the DNS is configured correctly you just have not forwarded it in the panel to the right folder. Have a look at this: mrmagne.com/wildcard-domain-on-plesk-11 What folder is your document root pointing at? – Guerrilla Apr 29 '15 at 10:21
  • Yes, you smashed it @Guerilla. Following the instructions at the end of your link above and adding the wildcard subdomain in Hosting Settings with the document root pointing to httpdocs has it all working now. I'll have a play around with those other two previous measures (the CNAME record and the vhost.conf edit) to see if all three were necessary. Nice one. – Kevin Nugent Apr 30 '15 at 9:38
  • NB: I had previously tried adding the server alias with quotes as well as without but it made no difference. I still don't know therefor if they're necessary in Plesk 12. – Kevin Nugent Apr 30 '15 at 9:39

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.