0

This question already has an answer here:

Hope you are fine and in a good health.

I owned a blog www.ismag.com and today when I check my website in Google webmaster tool I found these errors in html improvement.

enter image description here

I am using WordPress SEO by Yoast. Please help me to solve this issue.

marked as duplicate by Pieter Goosen, Howdy_McGee, cybmeta, s_ha_dum May 29 '15 at 14:18

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

0

Your case is not about the yoast plugin. You have duplicate on a lot of pages, with 2 slashes in the end. It seems the cause for this is your "share box" plugin or something like that, the one who gives the options for sharing/comments on the thumbnails, and more specifically - the comment one. Check for example http://www.ismag.com/category/technology/tech-news/, on the hover of any of the thumbnails, the comments lead to the wrong doubleslashed version. The fix should be easy, most probably there is slash in the plugin file referencing the comment button itself. I just have no idea which plugin is this, but anyway - this is your problem.

  • Hello... this is the answer from theme developer : prntscr.com/7af90n Link : stackoverflow.com/questions/7780859/… – Anas Khan May 28 '15 at 16:42
  • I have found this function in my function.php file. // Prevents double posts on second page add_filter('redirect_canonical','pif_disable_redirect_canonical'); function pif_disable_redirect_canonical($redirect_url) { if (is_singular()) $redirect_url = false; return $redirect_url; } When I remove this function the problem of trailing slash disappears. Can you please tell me what originally this function is doing ? – Anas Khan May 29 '15 at 7:39
0

Ensure these are enabled (See images)

enter image description here enter image description here

Not the answer you're looking for? Browse other questions tagged or ask your own question.