0

With Wordpress 4.2 planned to be released next week, I was wondering about the finalizing of the new WP-views API. Apparently even the more simple examples of mce are failing in 4.2. I know that api is "experimental" but it hasn't had too much change in the last few releases. Has anyone started a migration guide for the developers registering their own mce-views?

  • Is the hint to a post not good enough to play with this new view? – bueltge Apr 22 '15 at 15:05
  • 1
    @bueltge That looks like a good overview for writing a plugin+preview in editor, but that is quite unrelated to my question as they are actually doing their own editor.on('BeforeSetcontent' and editor.on('GetContent' TinyMCE handlers, not the Wordpress-views wp.mce.views.register function. – NoBugs Apr 23 '15 at 0:38
  • Your comment is helpful for me to understand your goal. – bueltge Apr 23 '15 at 4:51
  • 1
    Maybe this helps you - make.wordpress.org/core/2015/04/23/… – bueltge Apr 23 '15 at 13:27
  • @bueltge I think that's the answer, for now. Thanks – NoBugs Apr 26 '15 at 23:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.