0

We have a Raspberry Pi running PressPi which is a wordpress server. Our goal is to setup a Captive Portal using dnsmasq where users who connect to the Pi using a USB WiFi adapter see the PressPi home page when they attempt to surf the web. /etc/networks/interfaces (Rasbian) has been configured with a static IP address and correctly leases an IP address to clients. When these clients navigate to the PressPi server using the Pi's IP address, they see a broken layout whereas connecting to the Pi at http://localhost/ using the Pi's desktop renders the PressPi home page correctly.

Tried and failed:

  • I'm not familiar with Nginx and thinking it could be an issue with its configuration, I installed and configured Apache2 but this didn't fix the issue.
  • Confirmed that the entire directory including its content is owned by www-data and tried different permissions (775, 755, 777), all to no avail.
  • Setup a fairly complex HTML site and that rendered properly over the network.
  • Viewed all associated log files and there was no information related to my current problem. And that was expected since there were no errors.
  • Manually updated WordPress Address (URL) and Site Address (URL) to the Pi's static address (http://192.168.1.185) by defining them in the wp-config.php file and confirmed the change from the Admin CP.

I can't think of any reason why I get a broken display over the network, but not on the Pi's desktop. I appreciate any suggestions.

UPDATE This is a Wordpress problem. I suspect something to do with a path update as other applications render properly over the network.

3
  • maybe it is a wordpress problem, maybe not (most likely it is not and it is a server, theme or plugin problem). One thing is sure, you didn't provide any detail that will enable anyone to help you. Apr 10, 2015 at 11:58
  • @MarkKaplun Thanks for your comment. What additional information should I provide?
    – Ralph
    Apr 10, 2015 at 12:01
  • frankly, you need to isolate the problem otherwise there are just too many posibilities. Is the problem is with the theme and other themes work currectly? maybe it is a specific plugin? and does it happen because a css fails o load, or maybe some different css is loaded? and if fails to load do you get any error in your nginx log?. Most likely after you have issolated the actual issue the solution will be obvious even to you, but even if not at least it will be possible to try to have some educated guess were the problem might be and suggest additional debugging steps Apr 10, 2015 at 12:07

1 Answer 1

0

I know this is late, and you might have found the answer already, but I suspect you'll need to do a serialized search and replace on the DB. You can't just change the WP domain name in wp-config.php. The database still has entries for the setup domain name, whatever that might be (localhost?). You can use this tool: https://interconnectit.com/products/search-and-replace-for-wordpress-databases/

I use version 2, as it is just a .php file, but version 3 has a more useful interface. You'll need the DB creds, the old url ("localhost"), and the new one (your IP, in this case.) After this, you'll only be able to see a working, non-broken version, at the IP.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.