1

I have a wodpress site, and I have submitted it to google webmaster tools. When I search on google by my site name, the results come, and on clicking the searched result, I can open the website on my PC. But when doing the same thing on my mobile, i get this

Error 406: Not accebtable

How can can resolve it?

1

I had a similar problem recently with this 406 Not Acceptable error occurring when trying to update permalinks in WordPress. I also had the same problem when submitting any changes to the editor, etc. Google Webmaster tools would yield the same result.

The solution is to disable the mod_security firewall within your .htaccess file.

My fix was to install a plugin called "WP Htaccess Editor" (free WP plugin), then update the .htaccess file to the following, between the "Begin WordPress" and "End WordPress" tags:

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

Hope this helps.

| improve this answer | |
1

A 406 Not Acceptable HTTP error usually indicates that the content type of your webpage is not in the Accept request header that your browser sent to the webserver.

When you load a website, your browser sends a Accept header with the content types that it will accept, like text/html or text/xml. But when the webserver sends a format your browser doesn't accept, it will give you a 406 HTTP error.

My guess is that a plugin or theme is changing the content type header, or your phone's browser is acting weird.

| improve this answer | |
  • 1
    Really I can't thank you!! All other answers are trying to tell a solution without defining the problem. – Shady Mohamed Sherif May 28 at 5:12
  • You're welcome! – redelschaap May 28 at 9:16
0

This happened to me while using WooCommerce API for Node JS. I just changed the verb put to post and it worked.

| improve this answer | |
0

Here was fixed using this lines on .htaccess file (public_html)

   <IfModule mod_security.c>
SecFilterEngineOff
SecFilterScanPOSTOff
</IfModule>
| improve this answer | |
  • Can you add more to your answer to describe why this fixed this problem and what it does? – mozboz Jul 29 at 9:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.