0

I have a WordPress website running on a machine. PHP has allocated memory of 128MB. Since I have two WP sites being host under same hosting it is consuming around 95MB out of 128MB on normal load..

I wanted to move new theme with custom fields types (Advanced Custom Fields). We created a test environment on other server. Developed theme their and prepared the content we require to move on production website (posts, pages etc with custom fields). Since we were done with development. I wanted to move it to the mail website.

While trying to import the WordPress backup, server just went down and I could see the following message displaying when I tried to refresh the page / hit the homepage.

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

I didn't get Fatal memory error that means the website does not have memory issues..

Most of the times, I can see almost 95% of the memory is being utilized. What could be the error?

Edit : We already have allocated more memory to PHP (i.e. 256MB) but I still get the same error.. Now, the site is totally down and I have no idea how to make it up again.

2

Sorted it out myself.

The problem was, server was very slow to process the import. The process was happening behind the scene but server actually went down.

When server was up, I could see all the content on the other site.

1

When I had developed a theme, and I was trying to automate the import process by tweaking wordpress-importer plugin. I had faced the same issue.

When importing server processes numerous DB operations at same time, that's why it's not able to respond and it results in 500 Internal server error.

Try 1 :

To fix the issue, you have to import one by one. Whatever importer you are using, tweak it such that it works with AJAX and imports data with some time gap.

setTimeout( function () {
   $.ajax({
      // import one part of your data
   });

}, 2000 ) ; 

Try 2:

Try setting time limit of PHP to 0. Put this in starting of your importer's main file.

@set_time_limit(0); 

You are not getting fatal error, still you should to give it a try.

-1

Please check your .htacess files there might be some issues in it. You may even try to rename it.Hope it helps I was stuck with similar issues little time ago.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.