0

I'm creating a custom theme on a local install on WordPress on Ubuntu. The theme is a separate directory within /themes/ and has both index.html and style.css. It works on other installs. I have made myself the owner and increased the permissions to no avail. Any other ideas?

1
  • 2
    I was struggling with this last night and came across your post. It was inexplicable. Nothing worked. In the end, I had forgotten that I had set up a Multisite. And on multisite, you have to manually enable any themes you want available to the network (or a specific site) in the Network Admin area. Just in case this could help somebody else...
    – Jake
    Sep 22, 2017 at 20:33

1 Answer 1

2

Please learn how to template for WordPress first, before proceeding further. It will help you understand how you are proceeding and what you are achieving.

Please note what is the Minimal requirement for a theme to BE a 'theme':

  • index.php (not index.html)
  • style.css

That's it.

It will work like a complete theme, and you can activate the theme without any harassment.

But to make it a complete theme you have work a lot, and you have to start from the style.css and functions.php... all are explained here in Codex:

4
  • I understand all of that. Forgive me the index.html was a typo. I meant index.php. As I mentioned the basic theme I am using works on other Wordpress installs but not mine. Here's a link: github.com/rsteggy/Simple-Blog Again it's in the themes folder, I've changed permissions, and made myself an owner which were the only other troubleshooting steps I found for this issue. Mar 25, 2015 at 18:12
  • <!DOCTYPE html <?php language_attributes(); ?>> in header.php is a wrong declaration. It should be on the next line <html <?php language_attributes(); ?>>. Mar 25, 2015 at 18:20
  • I updated that in my header.php but the theme is still not showing up on my local install Mar 26, 2015 at 20:15
  • I follow a basic debug rules I made: I simply cut ctrl+x a portion of the code, from the main template files (functions.php, index.php, header.php, footer.php etc.) and save ctrl+s the file and then reload the front-end. If that portion is causing the problem and everything else is okay, the page will load, and I can then concentrate on that particular portion of the code. Mar 27, 2015 at 6:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.