1

I ran the automatic upgrade from 3.8.5 to 4.1.1 but had fumbled the backups. Now in the admin area only the wp-admin/about.php?updated page works showing me "Welcome to 3.8.5" and inviting me to upgrade again. If I click any other link such as Users or Post I get a white screen and a 500 error in the log. Clicking on the upgrade button seems to work in that it prints up the full upgrade steps it is running including the database upgrade. Yet when it finishes it reloads the page and it still says its is version 3.8.5 and nothing is fixed. Manually upgrading using the Upgrading_WordPress_Extended to delete and copy files doesn't fix it. Looking in the logs when I click on Users or Posts I see HTTP 500 errors such as:

81.2.110.237 - - [19/Mar/2015:04:32:50 -0400] "GET /wp-admin/users.php HTTP/1.1" 500 - "http://XXX/wp-admin/about.php?updated" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_2) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2272.89 Safari/537.36"

The public front of the site is working fine its just the admin area which is trashed. Given that I have run the "extended manual upgrade" without that clearing the issue what can I do to force through the upgrade and remove the broken redirect to about.php?updated.

Some more information:

  1. The site is running on a redhat openshift php-53 cartridge.
  2. Running md5sum * run in wp-admin folder of the site then comparing the output with same run in the folder unzipped from wordpress-4.1.1.zip shows that it is 4.11 on the site. Ditto for wp-includes folder. Going to /wp-admin/upgrade.php shows Your WordPress database is already up-to-date! so it seems my database is up to date.
  3. Guessing it was silent failure to overwrite files due to permissions I did chown -R me:mygroup * to see if there were any files owned by some system account which gave no errors then chmod -R o+w * to give world write. Then I reran the automatic upgrade on the page the admin area is stuck on. Once again it ran to completion without errors but nothing got fixed. So I have run chmod -R o-w * to revert world write.

Then things get really weird. I backup the db and site folders on the linux host and restore them in a local MAMP install on my mac. When I got to login to the local copy it says Database Upgrade Required so I run that, it all works, and I can use the site locally all fine. So now I think all I have to do is restore the upgraded local database back into the server then I will be all good. So I restore the database, hit the wp-admin, and get Database Upgrade Required. Okay maybe the restore didn't work but this looks like progress. I click Upgrade WordPress Database and it hangs showing no put stopped at the url wp-admin/upgrade.php?step=1&backto=%2Fwp-admin%2F. I look at the server database and it has the same rest password hash I set locally so I actually think I had installed the copy of the working local database (upgraded) into the server. Dumping the linux database and comparing it to the last backup the primary key of the comments table has changed so it would appear that the database has now had some upgrade code run against it.

Digging around in the backups I see that the options table has a load of site configuration in it. The latest backup shows:

(56,'db_version','30133','yes') 
(164,'db_upgraded','','yes')

and the wp-includes/version.php shows:

$wp_version = '4.1.1';
$wp_db_version = 30133;

So the system thinks it is update as the db_version is correct.

1

Eventually after confirming that the database had been updated I rebooted the server I tried moving the file wp-admin/upgrade.php to be wp-admin/411.upgrade.php. This got the site out of its death spiral.

Given that I had manually updated all the files using Upgrading_WordPress_Extended and had also managed to get the database upgrade installer to run as shown by the db_version being 30133 entry in the _options table if you run into the same problem trying moving that script out of the way.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.