-2

I've created my template and installed extensions everything worked fine. I work on localhost and then upload to my server and use searchreplacedb2.php to change the root url as usually.

But now, I can login and then access wp-admin in localhost, but on my server I can login (correctly and have the admin bar on top of the website pages), but I have a blank page a wp-admin/

I desactivated all security (extensions desactivated and files modifications removed in :function.php, wp-config.php, .htaccess updated on server) used on localhost, and uploaded the SQL database again, but no change, I still have a blank page.

define('WP_DEBUG', true); → wp-admin still blank page

Where should I search for a solution ? Thanks for help !

0

WP 4.1.1 seems to need a lot more memory than previous versions. Just add

define('WP_MEMORY_LIMIT', '256M');

in your wp-config.php file just before the /* Stop editing */ comment line and you should get rid of the blank screens. If you can't access that much memory, go for less, but from my tests the minimum required is 96M. This is probably a bug and will prolly get fixed a.s.a.p. by WP devs. WP is supposed to run fine on 64M, or even 48.

EDIT: I wrongly assumed you have the memory leak bug that seems to be quite big at the moment related to updating existing WP installations to the latest patch. Your issue has to do with wrong options set in your DB. Here are the SQL queries I run when moving WP installations to a new address:

UPDATE wp_options SET option_value = replace(option_value, 'http://www.old-domain.com', 'http://www.new-domain.com') WHERE option_name = 'home' OR option_name = 'siteurl';
UPDATE wp_posts SET guid = replace(guid, 'http://www.old-domain.com', 'http://www.new-domain.com');
UPDATE wp_posts SET post_content = replace(post_content, 'http://www.old-domain.com', 'http://www.new-domain.com');

Without any logs I'm afraid I can't be of any further help.

  • I can't find /* Stop editing */` on french wp-config.php. I added it just before // ** MySQL settings ... But no result with 256, 128, 96, 64 or 48. wp-admin appears correctly on localhost, but not online. Any other idea ? Thanks ! – Nonoseki Mar 19 '15 at 10:43
  • thanks but I found the solution. Anyway, I'll keep your SQL queries tu update the database after transfert. I've also tried to edit .sql file and change old-domain.com to new-domain.com, isn't it good or dangerous ? – Nonoseki Mar 19 '15 at 21:09
  • Hard replacing in .sql files is not recommended. The success rate depends on the operating system, the editor and the encoding you use, on the collation of your .sql file and whether or not you have special characters in your content. In short, when editing directly an .sql file of an existing WP website, you have higher chances of corrupting it than of not corrupting it. SQL queries are much safer. Of course, you should always have an unmodified backup of your .sql file, just in case you mess it up. – Andrei Gheorghiu Mar 26 '15 at 20:24
  • thank you for your answer. I'll keep your SQL queries for next update. – Nonoseki Mar 29 '15 at 8:06
-1

When exporting a DB from localhost, you are much better off opening the sql file in a program like notepad++ and doing a "find replace" on the URL before importing to your server.

I find that these type of plugins do more harm then good.

Exporting from localhost goes like this for me:

Export DB
Open `sql` file in notepad++
Find Replace the URL with the one on your domain
Import DB (.sql file)
edit and upload wp-config.php

Works Everytime without problem

  • 1
    I find that the plugins do more harm then good. is a generalization that does more harm than good. I think that the plugin system gives WP a level of flexibility that is one of it's major pluses. Of course, people writing bad plugins will cause more harm than good. Are you suggesting a different system? Please elaborate. – Andrei Gheorghiu Mar 19 '15 at 12:02
  • I find that the plugins do more harm then good Is my opinion based on my experience with these types of plugins, you can't beat making manual changes within an sql file. – CodeX Mar 19 '15 at 12:07
  • Oh, searchreplacedb2.php is not a plugin? – CodeX Mar 19 '15 at 12:14
  • I'v just tried to replace with sublime text, but still blank page for wp-admin. Any other idea ? Thanks ! – Nonoseki Mar 19 '15 at 12:33
  • Are you using a caching plugin? – CodeX Mar 19 '15 at 12:34
-1

I've faced this kind of problems few times. The problem may occurs for: Memory Limit Cache Plugin Problem

Uninstall all Plugins. If it's not solved the problem then the way I'd solved was, rename "wp-admin" folder and upload a Fresh Downloaded "wp-admin" folder. Hope it helps you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.