0

I am posting data in wordpress but after click on public it is showing

This is somewhat embarrassing, isn’t it? It seems we can’t find what you’re looking for. Perhaps searching, or one of the links below, can help.

I dont have any idea how to resolve this. I am using wordpress4.1 Screenshots

enter image description here

After click on publish

enter image description here

12
  • Could you please attach some screenshot so we can have an idea of your issue?
    – jepser
    Commented Feb 27, 2015 at 5:34
  • You will need to give more info on this. From what you have given, I can only speculate that you are using custom post types which is excluded from the main query, and this will lead to the failure you are seeing visiting your homepage Commented Feb 27, 2015 at 5:35
  • @PieterGoosen ,@jepser Please see the edit
    – xrcwrn
    Commented Feb 27, 2015 at 5:46
  • That does not help at all. My question is, are you using custom post types? If not, then it is impossible to say what is causing this, and might be theme related, something in the region of a custom filter, bad template file ... Commented Feb 27, 2015 at 7:31
  • NO not using custom post types
    – xrcwrn
    Commented Feb 27, 2015 at 9:16

5 Answers 5

1

Please reset your permalink. Go to http://yourdomain.com/wp-admin/options-permalink.php and just click Save Changes button.

Edited: Try these steps:

  1. Make sure the homepage exists. Go to Settings > Reading options, see which page is used for homepage and check this page's status.
  2. Update WordPress. Keep backup before you proceed.
  3. Check each of the plugins. Deactivate and re-activate one by one and see what happens.
  4. It may happen that modSecuriy process is checking the wp-admin and the input of data. Edit the modsecurity whitelist-

vi /usr/local/apache/conf/modsec2/whitelist.conf

Add this code

<LocationMatch "/wp-admin/*"> SecRuleEngine Off </LocationMatch>

then restart apache. /etc/init.d/httpd restart

4
  • Not working I have selected(default) Post name example.com/sample-post and save change
    – xrcwrn
    Commented Apr 9, 2015 at 7:25
  • I have edited my answer. Did you check it?
    – mukto90
    Commented Apr 11, 2015 at 15:22
  • I have done upto step 3 then tried to post again same problem. I am using cpanel where how to use 4 and above step i am not getting
    – xrcwrn
    Commented Apr 13, 2015 at 9:32
  • Simple updating of permalinks worked for me! (Clicking "Save Changes")
    – rinogo
    Commented Apr 14, 2016 at 23:01
1

This is can be because of following reasons.

1.Premalink problem. Go to settings -> permalinks and set to default. save and check if post is now showing. If its working fine then reset premalink structure to desired one (like postname), save and check.

2.rewrite problem in .htaccess file Check if url is re-written in htaccess file or if it is then it rewrite rule is proper.

3.Url rewrite from functions.php file Check if urls are overridden in function.php file.

4.Post is in draft or not set to public

5
  • 1 done not working for 2 what to check in .htaccess file
    – xrcwrn
    Commented Apr 13, 2015 at 9:50
  • can it see stores error log anywhere??
    – xrcwrn
    Commented Apr 13, 2015 at 9:50
  • What is your current permalink structure ? Can you post site url and post url that is giving 404 ?
    – Vikram
    Commented Apr 13, 2015 at 13:24
  • I am using Post name as default and my site name is www.ebhor.com
    – xrcwrn
    Commented Apr 15, 2015 at 9:06
  • Did you check post status? it should be published. I had a look on screenshot above and found that post is in draft.
    – Vikram
    Commented Apr 16, 2015 at 4:01
0

Goto settings -> permalinks option and change the common settings. Check the post again.

If this does not work then check the .htaccess file.

1
  • what to check in .htaaccess file?
    – xrcwrn
    Commented Apr 13, 2015 at 9:51
0

Did you enable WP_Debug ?

  1. Go to File Manager.
  2. Locate the wp-config.php file for your WordPress website.
  3. Click Edit for the wp-config.php file.
  4. To enable WP_Debug, add the following code to the end of the file:

    /**
    * WordPress Debugging
    *
    * Set to "true" to enable wp_debug. Set to "false" to disable.
    * Do not include quotes when setting to "true" or "false".
    */
    define( 'WP_DEBUG', true );
    
3
  • Initially not enabled just done it. Where it will show debug
    – xrcwrn
    Commented Apr 13, 2015 at 10:33
  • it will show you the errors & warnings in the website (if you haven't use any error suppressing )
    – Malay M
    Commented May 7, 2015 at 11:32
  • Well I am unable to resolve my problem
    – xrcwrn
    Commented May 11, 2015 at 6:45
0

Well i had something similar and i was banging my head why when i was editing an existing post it was fine but when i was doing one on my own it was simple ... " not found "
The "key" is the slug, since i am from Greece , using Greek letters for my posts and subsequently the slug was "getting" the Greek heading it would simply won't work.
Changing slug to Latin letters was the key to "success"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.